X10 Community Forum

🖥️ActiveHome Pro => Plug-ins => OnAlert => Topic started by: EdwinWeston on September 14, 2006, 10:18:09 PM

Title: Help file
Post by: EdwinWeston on September 14, 2006, 10:18:09 PM
Nothing happens when I click on "Plug-ins" -> OnAlert->Help.
The ahp_security.chm is the same as ahp_smartmacros.chm
Any suggestions?
Title: Re: Help file
Post by: JMac on September 15, 2006, 08:01:03 AM
Don't believe there is anything there yet...........
Title: Re: Help file
Post by: RJMiller on September 15, 2006, 05:44:39 PM
There is a pretty good (but short) description of how it works in the wiki database

  RJ
Title: Re: Help file
Post by: CLacina on September 15, 2006, 10:43:11 PM
Here's a copy of the help file.  You'll have to rename it from ahp_security.doc ahp_security.chm.
Title: Re: Help file
Post by: dawgpile on April 18, 2007, 11:28:01 PM
I have the same problem as Edwin.  Nothing happens when Help is selected.  I dowloaded the ahp_security.doc and renamed it as CLacina suggests.  (I renamed the one that was there to save it)  I can open it directly from Windows Explorer(and it's the proper help file) but it won't open within AHP when selected from Plug-Ins>OnAlert>Help.  My ahp_security.chm that was installed originally was the same as Edwin's(for the SmartMacro plug-in, NOT the OnAlert)

Does anyone know how to get the help file to launch properly when selected for Plug-Ins>OnAlert>Help ???  I get no response when I select the Help button from the Plug-in pane or from the drop down menu.  Help please!  Thanks in advance for your consideration.
Title: Re: Help file
Post by: HA Dave on April 19, 2007, 07:56:09 PM
Title: Re: Help file
Post by: MikEroNet on November 02, 2007, 01:31:14 PM
Unfortunately that doesn'tít work for me. But if it did the original file (which is the same as ahp_smartmacros.chm) should have come up when I go to plug-ins->on alert->help; but nothing happens when I click on that menu item before or after updating the file. I went through the AHP.dll with a hex editor and there are references to all the other *.chm help files except for the OnAlert so I assume this is a programmer error.† :-\
Title: Re: Help file
Post by: HA Dave on November 02, 2007, 02:11:30 PM
Unfortunately that doesn'tít work for me. But if it did the original file (which is the same as ahp_smartmacros.chm) should have come up when I go to plug-ins->on alert->help; but nothing happens when I click on that menu item before or after updating the file. I went through the AHP.dll with a hex editor and there are references to all the other *.chm help files except for the OnAlert so I assume this is a programmer error.† :-\

MikEroNet it doesn't sound to me as if you actually have the OnAlert plugin installed. Call X10 (and have your purchase order info handy). X10 will glady sent you a new link.
Title: Re: Help file
Post by: MikEroNet on November 04, 2007, 01:36:28 AM
I installed and registered my version. It comes up as registered when I start the app and all the functionality for it is available. On the about screen (Plug-ins->OnAlert->About) it says I have version 2.206 (Last Update 09-11-2006). Is there a later version then this? It appears to all work other then the help.
Title: Re: Help file
Post by: Puck on November 04, 2007, 10:31:00 AM
I installed and registered my version. It comes up as registered when I start the app and all the functionality for it is available. On the about screen (Plug-ins->OnAlert->About) it says I have version 2.206 (Last Update 09-11-2006). Is there a later version then this? It appears to all work other then the help.

The latest version with OnAlert should say: 3.206
I looks like you probably made a typo.

Look up (http://www.x10community.com/forums/index.php?topic=10167.msg58678#msg58678) to get a copy of the correct OnAlert help file. It's attached to CLacina's post.
Title: Re: Help file
Post by: MikEroNet on November 04, 2007, 11:21:38 AM
My bad, it's 3.206. I have the help file already thanks. I was just trying to see if I could get it to work within the application but it doesn't seem possible. Not a big deal since I can of course read it without the app.
Title: Re: Help file
Post by: Puck on November 04, 2007, 12:14:54 PM
I was just trying to see if I could get it to work within the application but it doesn't seem possible. Not a big deal since I can of course read it without the app.

Good point, it's been so long since I used it I forgot that the OnAlert Help doesn't work. Hope it's not too late to get added as a recommended fix (http://www.x10community.com/forums/index.php?topic=13550.msg77281#msg77281).