X10 Community Forum

Reviews => X10 Web Site Reviews => Old X10 web sites => Topic started by: Malisaw on April 26, 2008, 09:35:11 AM

Title: How bad is the website ?
Post by: Malisaw on April 26, 2008, 09:35:11 AM
 ::)

I use a host file I download and keep updated that blocks known spam/malware/adware/nuisance popup sites, etc.....  redirects them all to the local port.  Well, when I found the product I was interested in by googling and went to click on it...I couldn't load the page.  Did a little checking and the X10 site is such a nuisance site that it is blocked by most of the host files available on the net.

I'm amazed that they have such good products (I've used 3 different products of theirs to date -- the video sender/receiver is the first I've used in about 6 years though)... and such pathetic marketing ploys that they are known on the net as a nuisance / spam site.

They sure need to spend some time enhancing the image they've managed to establish over the past years!  :( :(

Love the products, hate the marketing!  >:(
Title: Re: How bad is the website ?
Post by: Brian H on April 26, 2008, 12:46:08 PM
My Spyware program also blocks X10s sales site by default. For me to look for products I have to allow them access.
In former years X10 was very bad at spamming your mailbox. They are now much better but I would guess the reputation lingers.
Title: Re: How bad is the website ?
Post by: steven r on April 26, 2008, 01:41:40 PM
...Love the products, hate the marketing! 
Most people of intelligence agree.

My Spyware program also blocks X10s sales site by default. For me to look for products I have to allow them access.
In former years X10 was very bad at spamming your mailbox. They are now much better but I would guess the reputation lingers.
I use a host file I download and keep updated that blocks known spam/malware/adware/nuisance popup sites, etc...
X10 was the 1st company to use the "pop under ads". Most default host files designed to block ads block access to X10 sites also. I had to edit mine to allow access to the X10 site for the rare times I go there. Their web site has driven me to buy most of my needs elsewhere.
Title: Re: How bad is the website ?
Post by: JimC on April 28, 2008, 06:20:26 AM
My ISP blocks X10. I am unable to receive emails from X10. What a pain, I am not notified of responses to my posts and I never get emails from their sales site even though I have requested them.  :( :(  My ISP has told me that they block what they concider nuisance  sites.
Title: Re: How bad is the website ?
Post by: dave w on April 28, 2008, 12:04:24 PM
My ISP blocks X10. I am unable to receive emails from X10. What a pain, I am not notified of responses to my posts and I never get emails from their sales site even though I have requested them.  :( :(  My ISP has told me that they block what they concider nuisance  sites.

And they give you no control or say over this??
Title: Re: How bad is the website ?
Post by: JimC on April 28, 2008, 12:20:33 PM
Quote
And they give you no control or say over this??

To my surprise NO. I was told that the only way to have this changed was to have the offending site complete some "necessary"paperwork and submit it to them.
I have not had time to pursue it beyond this. >:(
Title: Re: How bad is the website ?
Post by: Dan Lawrence on April 28, 2008, 05:12:16 PM
What's interesting is my ISP, Comcast does NOT block the X10 site.  I've Never got an e-mail from X10 except when I first ordered AHP and the CM15A in 2005 and FedEx decided not to deliver my order when it was supposed to arrive (Friday), so I called X10 and they were going to reship me a new order and e-mailed me about it.  Then, the following Monday, a package from X10 was sitting on my porch.  Seems the FedEx driver didn't want to work on Friday. I called to stop the new order and they did, plus sent me a confirmation e-mail.  I've since received a couple of e-mails about the forums. 
Title: Re: How bad is the website ?
Post by: Tuicemen on April 28, 2008, 05:21:10 PM
My ISP also blocks X10 e-mail by default (uses yahoo)!
By loging on to My ISP homepage then viewing mail from there I can tell it that X10 Mail is not spam!
I found I periodically have to do this (when ever a new feature is added to the ISP web page)  ::) :(
Title: Re: How bad is the website ?
Post by: JimC on May 07, 2008, 07:57:41 AM
Well, the only help that my ISP (Comcast) can provide is to tell me that X10 has been black listed. The only way for me to get email from them is to have them (X10) complete a form and submit it to Comcast  to get off the list. Comcast has stated, to me, that they do not accept individual requests to have this problem resolved and that only the offending site can resolve the issue. I have forwarded this information to X10 twice now and still have not received a response.

There is no way that I will buy software from X10 if it requires on line registration. I will never get the email containing the link and registration information.

Dan states that he has Comcast and is getting email from X10 so it must be a local issue.  ???
Title: Re: How bad is the website ?
Post by: steven r on May 07, 2008, 08:54:48 AM
I know at least one other person that has Comcast for their ISP that isn't having problems so it may be a local issue.
Seems like if one is paying for an ISP they should have the final say as to what is spam at least with respect to receiving email.
It's ashame that X10 is dragging their feet on the issue.
Keep forwarding to everyone at X10 maybe someone will wake up for you.
Title: Re: How bad is the website ?
Post by: JimC on May 07, 2008, 12:01:56 PM
Quote
It's ashame that X10 is dragging their feet on the issue.

The problem is that even if they wanted to email me to discuss the problem I would not get it. Guess I'll have to set up a Yahoo email account.  :-\

Title: Re: How bad is the website ?
Post by: JimC on May 07, 2008, 12:51:57 PM
UPDATE UPDATE UPDATE

To my surprise I just got an email from X10 (They used a Non X10 account to send it) informing me that they are working on the problem.
Title: Re: How bad is the website ?
Post by: steven r on May 07, 2008, 05:43:02 PM
The problem is that even if they wanted to email me to discuss the problem I would not get it. Guess I'll have to set up a Yahoo email account....
So is your email account blocking stuff from X10 or is the ISP blocking everything from X10. In the 1st case, you have a chance that a Yahoo email account would work. In the 2nd case, I don't think it would help.

...To my surprise I just got an email from X10 (They used a Non X10 account to send it) informing me that they are working on the problem.
Great! Keep that email address. You've found someone who cares.
Title: Re: How bad is the website ?
Post by: JimC on May 08, 2008, 08:18:09 PM
steven r,

It is the ISP that is blocking everything from X10.

What makes me mad is that I have no control over it. If there was a site I did not want to get mail from I would set my email filters to deal with it. I don't appreciate an ISP deciding what email to pass through.

Title: Re: How bad is the website ?
Post by: zach1234 on May 08, 2008, 10:11:30 PM
What about net neutrality, http://www.youtube.com/watch?v=cWt0XUocViE .
Title: Re: How bad is the website ?
Post by: Brian H on May 09, 2008, 06:39:58 AM
I have Automatic Notifications for replies; to my posts turned on. Now that is has been brought up. I have not gotten any; in a real long time and I did check my profile. It is ON.
Maybe Yahoo doesn't like X10. I know my ad blocking software and my Spyblocker both have a list I have to say X10.COM is OK. Default is NO.
Title: Re: How bad is the website ?
Post by: JimC on May 09, 2008, 06:59:57 PM
Quote from:
I have Automatic Notifications for replies; to my posts turned on. Now that is has been brought up. I have not gotten any; in a real long time and I did check my profile. It is ON.

I also checked my profile and it is also turned on. My mail program my block X10 by default but the emails never get that far. They never get past the Comcast mail program on the net as I can not even view them on the web. I have all of my filters turned off for Comcast web mail and still does not help.

Still waiting for X10 to resolve this issue. >:(
Title: Re: How bad is the website ?
Post by: JimC on May 16, 2008, 06:30:41 AM
I just started to receive the X10 news letter. Now I will wait and see if I start getting emails alerting me to responses to my posts.

Thanks X10 Web Master and staff.
Title: Re: How bad is the website ?
Post by: Tuicemen on May 16, 2008, 08:03:18 AM
JimC    I checked your notification settings and they apear to be set correctly! ;)
Title: Re: How bad is the website ?
Post by: JimC on May 16, 2008, 10:36:32 AM
Tuicemen,

Thanks. Guess they still don't have the problem completely resolved as I got no notification of your reply to my post. At least now I am getting the news letter.
Title: Re: How bad is the website ?
Post by: JimC on May 19, 2008, 07:19:51 AM
I started to receive forum alerts this weekend so I guess X10 resolved their problem with my ISP.

Thanks X10
Title: Re: How bad is the website ?
Post by: MassMadness on December 22, 2008, 03:12:31 PM
What about net neutrality, http://www.youtube.com/watch?v=cWt0XUocViE .

Net neutrality doesn't apply.  ISPs can and do block sites and emails based on specific content criteria.  They cannot (or should not) block based on the technology or protocol. (bit torrent is the usual example)