X10 Community Forum

🖥️ActiveHome Pro => ActiveHome Pro General => Software Problems & Bugs => Topic started by: yapper70 on June 15, 2008, 09:59:17 PM

Title: Smart Macros / On Alert
Post by: yapper70 on June 15, 2008, 09:59:17 PM
I have a macro that when a door is open a liight is suuposed to go on.  This works great until I add a condition that if the time is between 12:05 am and 6:30 am it does not play the macro.  If I change the time to 6:30 and 12:05 it works again except all the time.

any idea as to why this is happening?

I've attached a screen shot of the macro.

Thanks for your help.
Title: Re: Smart Macros / On Alert
Post by: jason.guenther on June 24, 2008, 12:03:42 PM
I have the same problem... tried many time ranges, tried dusk and dawn settings, tried to fool the software by flipping the AM and PM backwards... no matter what settings I use - the system only turns on during daylight, all the time, or not at all.  I have experimented with every upgrade for over a year - still isn't working.  Any ideas?
Title: Re: Smart Macros / On Alert
Post by: JMac on June 24, 2008, 01:35:37 PM
Yes, in here (forum) there is an explanation of OnAlert and time conditionals. "KDR" has an example setting up "Dummy modules" to accomplish what you want. I don't have time to look for it right now, but it's here, and it works. It's here: [Work-Around] Sending an E-Mail with OnAlert Using Conditions
Reply #1 on: April 08, 2007, 07:13:57 am
Title: Re: Smart Macros / On Alert
Post by: jayhalloran on June 24, 2008, 08:33:16 PM
I spent the better part of the last week or so trying to get the conditional time feature of macros to work with the same bad results.  It works fine if you use conditional days in place of time but that's not fine enough resolution for me.  I finally got in touch with X10 technical support and the gentleman I spoke with told me they have been playing with this problem themselves.  So - it is a known problem.  He had me email my file to him and said he would get back with me. I haven't heard back yet.  I will not be satisfied with some sort of work-around using dummy modules and flags.  The software should work as intended and, hopefully, X10 will recognize their obligation to provide a fix expediently.  When I hear back from X10 I will share it here.
Title: Re: Smart Macros / On Alert
Post by: yapper70 on June 26, 2008, 10:41:10 AM
I was starting to get nervous thinking this was only my issue.   

Hopefully X10 will find the bug and issue a fix soon. It's not like these programs are brand new they have been around for a while (which is part of the reason I took so long to migrate, I don't like being a beta tester).
Title: Re: Smart Macros / On Alert
Post by: JMac on June 26, 2008, 11:35:39 AM
I was starting to get nervous thinking this was only my issue.

Hopefully X10 will find the bug and issue a fix soon. It's not like these programs are brand new they have been around for a while (which is part of the reason I took so long to migrate, I don't like being a beta tester).

Well, while you are waiting for the update you might try the "KDR" reference above, or try my macro series (where Front Door Alpha [A15] & Front Door Beta [D6] are ghost modules). I agree that it's a shame that we have to resort to this, but after all if we get the system to work, isn't that worthwhile ?