X10 Community Forum

💬General Category => Mac/Linux & Open Source and the X10 Home => Topic started by: Senjak on January 26, 2010, 11:39:22 PM

Title: Off isn't 100% off?
Post by: Senjak on January 26, 2010, 11:39:22 PM

My big box of x10 toys arrived today.  I built the command line interface for Ubuntu mostly following http://www.somethinginteractive.com/2009/05/06/guide-x10-cm15a-ubuntu/

The first issue I ran into was that I had to add -LLIBDIR=/usr/local/lib to the LFLAGS when I built cm15demo.  Not a problem, easy.

Next issue I ran into is a little more weird.

I'm using an AM466 3 pin Appliance Module to control a Philips Blue Rope Lighting LED string.

"sudo ./cm15ademo a1 on" works great.  Snap sound as the power goes to full.

"sudo ./cm15ademo a1 off" not so perfect.  Snap sound and the lights to to very dim.  Dim, but still on, not off. 

Anyone have suggestions about what to try different?



P.S.  I tried the same experiment with the LM465 Lamp Module.  It doesn't even turn on.
Title: Re: Off isn't 100% off?
Post by: -Bill- (of wgjohns.com) on January 27, 2010, 02:30:51 AM
This is not a software problem.  The appliance module always outputs a small current.  For most appliances and incandescent bulbs, this is not enough to activate them, but the LED rope doesn't take much to glow dimly.  A "simple" solution is to add a small incandescent bulb like 4 - 7 watt "night light" in parallel with the rope lights.

At any rate, the software is switching the unit off as it should, it's an artifact of the actual appliance module.

The lamp module may be turning on to the most recently set level, newer ones do that.  Try sending a brighten command after the on command.

Title: Re: Off isn't 100% off?
Post by: Brian H on January 28, 2010, 04:31:46 PM
To make things even more confusing. The latest Soft Start Lamp Modules act differently than the ones from a year ago.
Sending a All Lights On and All Units Off commands. Now flash the lights for a Security Console Alarm Mode. Same goes for a one second on off cycle to the lamp modules address. The year old one I have tried to ramp on and off like soft start.

I would also say it is the small sensing current on the Appliance Module keeping the LED rope lights dimly on. Samething happens with low wattage LED Light Bulbs. The small light bulb is the normal fix as mentioned.