X10 Community Forum

🖥️ActiveHome Pro => Mobile Apps => Plug-ins => OnAlertMobile => Topic started by: Coyotefred on April 13, 2011, 11:37:50 PM

Title: OnAlertMobile stopped working after update
Post by: Coyotefred on April 13, 2011, 11:37:50 PM

I've been running OnAlertMobile now for several months on my smartphone with no issues (I just bookmarked the OnAlertMobile URL page that brings up the "remote control" and that allowed for quick and easy access).  I'm running AHP on a dedicated computer with no additional security controllers and just a few basic security modules.

But this last week I upgraded the operating system on this dedicated computer from XP Home to Windows 7, and now OnAlertMobile won't work.  As part of the upgrade process I re-installed AHP, but I saved the data file, so all the "old" settings are there unchanged.

The "invite a cellphone" option from the Plug-Ins menu in AHP worked fine and sent an e-mail with the same URL address I was using before the access the OnAlertMobile page.  But when I attempted to load the page it would just "hang" there without loading.

I've checked my router settings to make sure port forwarding for 8777 was still set up correctly and it is.  And I'm having no problems with other programs (Blue Iris and weather monitoring software) I also had to reinstall that used port-forwarding.  I have no other special security software running on this computer except for whatever Windows 7 would have installed as part of its basic install.  I checked the firewall settings and AHP is specified as an "allowed" program.

Yesterday I went into Windows 7 and set up a special "firewall rule" to allow any and all connections to port 8777 just to see if that would change anything.  The OnAlertMobile no longer "hangs," but I do get this error message:

                   500 Error - XServer: Invalid Parameters

'Any ideas?  Thanks in advance for any help!
Title: Re: OnAlertMobile stopped working after update
Post by: Coyotefred on April 17, 2011, 01:34:34 AM
'Just for future reference of those who may stumble on this thread in the future...  I ended up solving this problem by:

1. Uninstalling AHP using the standard program uninstall feature in the Control Panel
2. Downloading and installing each of my plug-ins one by one (WITHOUT having first re-installing AHP)

Once you're finished with this, go into the AHP folder in Programs and look for the AHP application.  Apparently it installs as part of the plug-in installation process since I didn't have to download/re-install it separately.  I just opened it up and voila, the old OnAlertMobile page opened just fine without issues.

There are probably other ways around this problem, but this worked for me.