X10 Community Forum

📱🖥️PiX10Hub ( Always Evolving Open Source) => 🏥Help and Trouble Shooting => 🧞HomeGenie ⛑Help => Topic started by: racerfern on February 18, 2019, 06:15:50 PM

Title: Screen Updates
Post by: racerfern on February 18, 2019, 06:15:50 PM
I've seen this talked about but I can't find it, so I'll have to post again.

I have a Pi3B+ with an Aeotec Z-wave stick and a couple of z-wave devices all included. HG is up and running but when I click to turn a device on, although it does go on, the HG screen doesn't update, sometimes for hours. If I hit 'F5' to refresh the status does update properly.

I have to assume the same would hold true for X10 devices. How do I fix this?

Title: Re: Screen Updates
Post by: Tuicemen on February 18, 2019, 06:57:47 PM
Are you double clicking or single clicking a device? or does it matter?
I always double click.  I seem to remember this issue with my 3B+ but assumed it was because I was running the full stretch (desktop version) I can't check that Pi out to see if the issue is still there I but I seem to remember reading a thread about this also but don't remember where It may have been on the Homegenie.club forum. ::) :'
Title: Re: Screen Updates
Post by: racerfern on February 18, 2019, 07:22:08 PM
Single or double clicking makes no difference, only refreshing the screen corrects it. This is not the way it should be.

However, if I VNC into the pi, then run chrome 192.168.1.54 I get immediate refreshes.  ;D

However going to 192.168.1.54 from my main PC does not refresh. :(
Title: Re: Screen Updates
Post by: bkenobi on February 18, 2019, 10:31:24 PM
I believe this can be resolved by flushing your cache.
Title: Re: Screen Updates
Post by: racerfern on February 19, 2019, 05:36:50 PM
I believe this can be resolved by flushing your cache.

Tried another browswer, Edge that I hardly use. Cleared everything, no joy.

Cleared most stuff out of Chrome still no joy.

Also flushedDNS although I didn't think that would do it. Still no good.
Title: Re: Screen Updates
Post by: Tuicemen on February 19, 2019, 05:45:48 PM
I wonder if this is why I started doing a nightly reboot with a cron job for my PI 3b+. ::) :'
Have you tried a service restart to see if that helped?
Title: Re: Screen Updates
Post by: racerfern on February 19, 2019, 07:51:29 PM
I don't think it's reasonable to have to expect to do a daily reboot of HG or any other HA software. However...

Service restart yielded nothing. Pi reboot yielded nothing. rebooting the PC I am using did nothing.


Title: Re: Screen Updates
Post by: Tuicemen on February 19, 2019, 07:54:11 PM
I don't think it's reasonable to have to expect to do a daily reboot of HG or any other HA software.
True, Nice to see the issue wasn't the Pi.
Title: Re: Screen Updates
Post by: bkenobi on February 20, 2019, 11:20:53 AM
Look through the issue posts on the HG github page.  If it's not there, submit it.  This is a bug in something (either your configuration or HG itself).  It needs to be understood so a fix can be provided.