Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Pages: [1] 2 3 ... 10

Author Topic: [AHP Add-On] X10WavPlayer (Add Sound)  (Read 237278 times)

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 264
  • Posts: 9404
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
[AHP Add-On] X10WavPlayer (Add Sound)
« on: October 25, 2006, 06:34:57 PM »

Since many wish to play wave files when AHP turns on /off something I created X10Wavplayer ;)
This takes nothing away from X10dispatch or BXVC in fact if you wish to have more options I suggest you down load those programs and test run them!
Although this is still  a work in progress I felt there was enough interest to release it! ::) ;) :D
How it works:
  • You call a batch file with a macro which will open the program and play a wave file
    .
  • The wave file must be in the sounds folder
    .
  • syntax is X10WavPlayer (filename) (true=loop false=no loop)
    eg: X10WavPlayer BADBOYS.wav false
    .
  • Don't Know how to make a Batch file!
    Not a problem version 1.2 now auto does this just click on "Create Bat File" located under "File"
    .
  • This will save the batch file as the wave file name with (rep) if you choose loop  but as a bat extention in the sounds folder
    eg: BADBOYS(rep).bat
    .
  • Note: You need Net Framework   installed for this to work!
    .
The file can be unzipped  and ran in any location even inside the AHP folder.
Want to have Active Home tell you what module activated?
Create a wave file using At&T Natural Voices ;) :D
Feel free to post any sugestions or comments here! ;) :D ;D
« Last Edit: August 29, 2007, 09:22:05 AM by Tuicemen »
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

KDR

  • Hero Member
  • *****
  • Helpful Post Rating: 53
  • Posts: 758
    • Home Automation Chat
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #1 on: October 25, 2006, 07:13:09 PM »

Nice Job Tuicemen !!  ;D

Going to give it a try.
Logged
Note: "Guests" may read the X10 forum , but you must register to post!

When I'm online you can find me in the Home Automation Chat Room!

Puck

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 171
  • Posts: 1799
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #2 on: October 25, 2006, 07:50:11 PM »

Nice Job Tuicemen !!  ;D

Tried the initial release last night & feel the same as KDR... nice little program.

Only option I'd like to see is to loop X times then close.  ;)
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 264
  • Posts: 9404
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #3 on: October 25, 2006, 10:50:00 PM »

Thanks KDR & Puck
Puck: I've got the repeat option added But I'm testing it right now  added repeat options of 0-9  plus Continuous if these aren't enough you can specify any number!
I'll try to post it to the my site Thursday evening! ;)
« Last Edit: October 26, 2006, 05:49:50 PM by Tuicemen »
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Puck

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 171
  • Posts: 1799
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #4 on: October 26, 2006, 09:12:33 AM »

...added repeat options of 0-9  plus Continuous if these aren't enough you can specify any number!
I'll try to post it to the my site Thursday evening! ;)

That's awesome Tuicemen... Thanks !!!  :)

Now if my DS7000 calls me, I will be able to hear in the background which sensor was violated.
Well in my case I don't have OnAlert yet, but I will be able to hear which motion sensors are triggered.

Hmmm.... may have to dedicate a status flag to prevent simultaneous annunciations... I'm sure I have plenty of spare flags left.  ::) :- :D
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 264
  • Posts: 9404
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #5 on: October 26, 2006, 06:14:39 PM »

  X10WavPlayer version 1.3 is now on the download site!
A few improvements:
  • As per Pucks request: added variable repeats
    .
  • Added a icon for the program exe
    .
  • added some wave files to the sound folder and one  made from the AT&T site mentioned earlier!
    .
  • The program now creates Batch files still using the sound files name but adds the repeat number in brackets at the end
    so "BADBOYS.wav" with 5 repeats  gives you "BADBOYS(5).bat"
    .
  • Note: the program is case sensitive so if you wave file is .WAV you need to change it to lower case for the auto batch file creator to work! ::) ;)
    .
  • if you wish to manualy create the batch files the syntax is:
    X10WavPlayer (sound file name) (number of repeats)
    eg: x10WavPlayer BADBOYS.wav Continuous
    .
;)I hope some of you Users find this Helpful! ;)
In any case please post your comments/suggestions Here! ;) :D ;D
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Puck

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 171
  • Posts: 1799
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #6 on: October 26, 2006, 07:42:21 PM »

;)I hope some of you Users find this Helpful! ;)

VERY MUCH :)
Logged

Dan Lawrence

  • Hero Member
  • *****
  • Helpful Post Rating: 68
  • Posts: 3991
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #7 on: October 27, 2006, 07:48:47 PM »

OK, I've downloaded everything, installed it all and it appears to work.

Can Tuicemen supply a sample macro, and can the macro be downloaded to the interface, or is it a PC macro?

The WavPlayer looks neat, and I think it will be useful.
Logged
I don't SELL this stuff... BUT I sure do ENJOY using it!!!

JimC

  • Hero Member
  • *****
  • Helpful Post Rating: 41
  • Posts: 631
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #8 on: October 27, 2006, 09:34:24 PM »

Thanks Tuicemen. This is a nice little program that is sure to come in handy.

Quote from: Dan Lawrence
Can Tuicemen supply a sample macro, and can the macro be downloaded to the interface, or is it a PC macro?

Dan, the macro can only be run from the PC as it requires the PC to run the batch file.
Dan, to use this you would have a macro that runs the batch file. This is located under advanced functions ......Windows Command.   In the Execute Windows Program box you enter the path to the batch file.

Hope this helps. If  not I am sure that Tuicemen can do a much better job of explaining it.

Jim
Logged
_ _ ...  ..._ _

Dan Lawrence

  • Hero Member
  • *****
  • Helpful Post Rating: 68
  • Posts: 3991
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #9 on: October 27, 2006, 11:13:27 PM »

I'm going to delete it.

I don't want a macro that runs only from the PC. 

It looked like a neat thing to have, but I'm not that interested in it.

Tuicemen  made a nice little program, but "freeware" that makes people do what they don't really want to isn't worth it.

Logged
I don't SELL this stuff... BUT I sure do ENJOY using it!!!

TakeTheActive

  • Hero Member
  • *****
  • Helpful Post Rating: 126
  • Posts: 1047
  • Old !@#$% Tinkerer!
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #10 on: October 28, 2006, 01:38:40 AM »

I'm going to delete it.

I don't want
a macro that runs only from the PC. 

It looked like a neat thing to have, but I'm not that interested in it.

Tuicemen  made a nice little program, but "freeware" that makes people do what they don't really want to isn't worth it.

IMHO, it's inappropriate / inaccurate / unnecessary posts like this that got you your original 60 "Unhelpfuls" that you whined to have reset to ZERO.  :(

When someone like Tuicemen invests their own personal time and effort (i.e. VOLUNTEERS) to create something even REMOTELY USEFUL by even a FRACTION of the "Community", and then decides to GIVE IT AWAY to others, *FREE* of any charges or strings whatsoever, you need to acknowledge *AND* respect their work / donation, *REGARDLESS* of whether or not you personally find their *GIFT* fitting to your needs. >:(


Another "poor taste", IMHO, example:

I have deleted BXVC from my system.  It will not allow me to add modules to A1, and it earased alll my old setup.

Unless you still have the prior version available, I'm done with it.

I have deleted BXVC from my system.  It will not allow me to add modules to A1, and it earased alll my old setup.

Unless you still have the prior version available, I'm done with it.

So... you downloaded the Upgrade version (not the Full version) and expanded / copied the files to the same folder you have been running BXVC from?

Yes and it screwed up my BXVC settings, lost every module and refused to allow a new A1 module to be added.
So, bye-bye to BXVC.
Loved the prior version, great to play with.  Downloaded the new version, copied the files to the folder, BLOOEY!!!

Did it ever occur to you to take this "conversation" to PM?

Did you ever stop to think about how much "hurt" you inflicted on -Bill- (of BXVC) by "bad-mouthing" his *FREE* (probably HUNDREDS of hours invested) contribution to the "Community" out here in PUBLIC?

Go ahead and DING me again! I know that the MAJORITY of my current 48 "Unhelpfuls" came from you! Posts like yours are *TOTALLY* uncalled for in a "Community" where folks come to help one another.


And I've also been recently informed by x10javier (aka Crabby Sysadmin ) that he's been getting LOADs of complaints about *ME*, yet I have only received *TWO* PMs:

  • Polite, IMO, request to a member to crop some 1280x1024 screen prints down to 1024x768 so that everyone (including the folks still using 1024x768 - poor eyesight, financial reasons, etc...) wouldn't have to horizontally scroll - FORCEFULLY REFUSED
    .
  • Unsolicited edit (by me) of 2 posts, minutes apart, with a (tiny 7pt) LINK to Tuicemen's Oops!! - DINGed

    In contrast, *MANY* of the folks that I show how to do something reply more along the lines of: "MY GOD thank you! I feel so dumb. I have been trying to figure that out..."
Folks,

If I do something that you find *TOTALLY* disagreeable:

  • *PLEASE* don't PM x10javier
    .
  • *PLEASE* don't just DING me
    .
  • *PLEASE* PM *ME* and TELL me *WHAT* exactly you disagree with! (I'm not a mindreader.)

    I've been spending a *LOT* of VOLUNTEER hours here, trying to make this place more "friendly" and "fun", getting Members to *TALK* to one another instead of just logging in to COMPLAINT about X10 - if I'm doing something wrong, *PLEASE* TELL ME!
[/size][/b]
Thanks!
Logged
Low Post Count != Low Knowledge - High Post Count != High Knowledge ;)

ADVICE TO X-10 NEWBIES FROM AN X-10 OLD-TIMER

Puck

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 171
  • Posts: 1799
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #11 on: October 28, 2006, 02:33:13 AM »

After seeing the last 2 posts on this tread, I sent this PM to TakeTheActive:

Re: X10WavPlayer(Add Sound to AHP)

I seen that post earlier and wanted to say something too... haven't been around long enough and not as outspoken I guess. But from what I seen of your posts and your character on this board, I knew it wouldn't go unnoticed / unaddressed. CHEERS!!! (wish I could pass you a beer)

You try to get people to read, think and appreciate that everyone here is volunteering their time & efforts to help... it's hard to believe how someone can interpret that as UNHELPFUL!
KEEP UP THE AWESOME WORK ON THIS BOARD TakeTheActive!!!

Dan

I'm sure I'm not the only Member / Guest / Lurker who appreciates what TTA does and tries to do for this board.
Logged

JMac

  • Hero Member
  • *****
  • Helpful Post Rating: 23
  • Posts: 462
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #12 on: October 28, 2006, 10:18:44 AM »

I don't contribute much, but I second the motion...........and added my helpful to Take the Active".
Logged

JimC

  • Hero Member
  • *****
  • Helpful Post Rating: 41
  • Posts: 631
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #13 on: October 28, 2006, 10:58:10 AM »

Quote from:
I don't want a macro that runs only from the PC. 


Dan,
Would you please explain how this program could be run from the interface. I was unaware that the CM15a had speakers hidden within that could be used to play the sounds.

Would you also please explain what the purpose of your post was. Why was it necessary to post anything negative about anothers efforts to improve AHP by developing add ons.

Just so you know who it was. I just gave you a negative for your uunthoughtful iinconsiderate post. Now go ahead and seek your revenge like you have on others. >:(


TTA, your post was right on and should be applauded.

Tuicemen THANK YOU, I  for one, find the program eextremely usefull and it was actually something I was looking for.

Jim
Logged
_ _ ...  ..._ _

KDR

  • Hero Member
  • *****
  • Helpful Post Rating: 53
  • Posts: 758
    • Home Automation Chat
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #14 on: October 28, 2006, 11:06:31 AM »

I also found it usefull and encourage Tuicemen and others to keep up the good work. Just because someone doesn't have a need for it or likes exactly how it runs doesn't make it bad. I support TTA's comments and others on this matter.
Logged
Note: "Guests" may read the X10 forum , but you must register to post!

When I'm online you can find me in the Home Automation Chat Room!
Pages: [1] 2 3 ... 10
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.