Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Pages: 1 [2] 3 4 ... 10

Author Topic: [AHP Add-On] X10WavPlayer (Add Sound)  (Read 241005 times)

Duck69

  • Hero Member
  • *****
  • Helpful Post Rating: 36
  • Posts: 246
  • Unselfish Love
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #15 on: October 28, 2006, 12:30:01 PM »

Ditto to Puck & JMac,  ;D 8)

I believe TTA receives a lot of unwarranted un-helpfuls and  that most of these are of  a personal nature.[/b]

If someone has a problem with TTA. Send him a personal message and work it out in private.[/b][/color]  ???

DON'T ABUSE the Ratings system.

x10javier, when is forum software going to be upgraded and some of our suggestions for improvements implemented ?

Tuicemen &  -Bill- (of BXVC) keep up your good work.
« Last Edit: October 29, 2006, 02:29:49 PM by Duck69 »
Logged
"I'm not lazy, I'm just Resistant to exertion."

Dan Lawrence

  • Hero Member
  • *****
  • Helpful Post Rating: 68
  • Posts: 3991
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #16 on: October 28, 2006, 01:48:03 PM »

Quote from:
I don't want a macro that runs only from the PC. 


Dan,
Would you please explain how this program could be run from the interface. I was unaware that the CM15a had speakers hidden within that could be used to play the sounds.

Would you also please explain what the purpose of your post was. Why was it necessary to post anything negative about anothers efforts to improve AHP by developing add ons.

Just so you know who it was. I just gave you a negative for your uunthoughtful iinconsiderate post. Now go ahead and seek your revenge like you have on others. >:(


TTA, your post was right on and should be applauded.

Tuicemen THANK YOU, I  for one, find the program eextremely usefull and it was actually something I was looking for.

Jim


Apparently, Jim, the macro can only be run from the PC.  That's because the sound files are on the hard disk. 

That's why I got rid of it.  It's not important to me to have a sound play in AHP when an action is taken.

TTA then decided to drag posts from the past to denigrate me.

Tuicemen did take the time to create a neat little program, I just don't need it. I downloaded it to see what it would do. It did, but I decided I didn't need it.

Logged
I don't SELL this stuff... BUT I sure do ENJOY using it!!!

Charles Sullivan

  • Hero Member
  • *****
  • Helpful Post Rating: 94
  • Posts: 1565
    • HEYU - X10 Automation for Linux, Unix, and Mac OSX
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #17 on: October 28, 2006, 02:49:23 PM »

Dan,
You're missing the point entirely.

When you download a contributed program and find it doesn't meet your needs, your posts ALWAYS come across as if you're sneering at the program.  There's no need to post anything at all - imagine what this forum would look like if everyone who happened to read a post about the availability of some program started posting responses like "I don't need anything like that".

If you download a contributed program that you think WOULD meet your needs but it doesn't seem to work right, PM the author about the problem and get his/her advice before publicly raising a stink.  For one thing, it may very well be "pilot error" and you'll avoid embarrassing yourself.

Logged
Yesterday it worked.
Today it doesn't work.
X10 on Windows is like that.

HEYU - X10 Automation for Linux, Unix, and Mac OS X     http://www.heyu.org

-Bill- (of wgjohns.com)

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 81
  • Posts: 1340
  • He's just this guy. You know?
    • wgjohns.com
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #18 on: October 29, 2006, 01:38:02 AM »

Dan,
You're missing the point entirely.

When you download a contributed program and find it doesn't meet your needs, your posts ALWAYS come across as if you're sneering at the program.  There's no need to post anything at all - imagine what this forum would look like if everyone who happened to read a post about the availability of some program started posting responses like "I don't need anything like that".

If you download a contributed program that you think WOULD meet your needs but it doesn't seem to work right, PM the author about the problem and get his/her advice before publicly raising a stink.  For one thing, it may very well be "pilot error" and you'll avoid embarrassing yourself.



Thank you Charles!  I couldn't have stated it better myself (except I would have used "annoying" font sizes and colors to emphasize my point)!   ;)

I also agree whole-heartedly with TTA's post!

Dan,
   I personally was quite annoyed with you publicly ranting about BXVC instead of PM'ing or emailing me for help.  Had I CO privileges, I would have deleted your post and PM'd you to help you work out your problem.  However, since I couldn't, I was forced to answer you publicly just so others would see that you were happy again.  I still don't know how many people have read that thread and have decided BXVC is not worth a look, just because (yes, I'm finally saying it!) you goofed the upgrade installation, you goofed further by deleting "everything" and therefore had to re-install from scratch and re-enter all of your settings.  Even with your "I'm happy now" post following, the thread still looks (to those who don't already know better) like BXVC might have been the problem.

   Your post here casts a similar shadow on Tuicemen's program.  I mean, how can; " ..."freeware" that makes people do what they don't really want to isn't worth it." be taken as anything but a dig?  It didn't make you do anything!  You chose to try it.  As JimC pointed out, what did you expect it to do, download firmware that caused the CM15A to grow speakers?

To all who read this,
   I beg your pardon for publicly venting my spleen at Dan!  I have no excuse.  I should have more self-control.  I just couldn't stay silent any longer.   :-[
Logged
-Bill- (of wgjohns.com)
bill@wgjohns.com

In the real world, the only constant is change.

When I'm online you can find me in the Home Automation Chat Room!

ArtClark

  • Guest
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #19 on: October 29, 2006, 02:44:26 AM »

I agree with TTA and all that was said.  Negative coments aren't of any use.  It's OK to vent, once in a while, but who am I to judge another.

After saying that, I would love to try out the program.  Sounds like what I have been looking for.

MY only problem seems to be, I can't get the link to work (My Bad, probably...).  My browser comes up with
Page cannot be found.    Could you please let me know what I am doing wrong.  I would love to try the thing.

P.S.  I tried both the original and updated version links.  Can't get either.  Maybe the server isn't running early in the AM??

TIA  Art.
Logged

-Bill- (of wgjohns.com)

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 81
  • Posts: 1340
  • He's just this guy. You know?
    • wgjohns.com
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #20 on: October 29, 2006, 04:19:20 AM »

I agree with TTA and all that was said.  Negative coments aren't of any use.  It's OK to vent, once in a while, but who am I to judge another.

After saying that, I would love to try out the program.  Sounds like what I have been looking for.

MY only problem seems to be, I can't get the link to work (My Bad, probably...).  My browser comes up with
Page cannot be found.    Could you please let me know what I am doing wrong.  I would love to try the thing.

P.S.  I tried both the original and updated version links.  Can't get either.  Maybe the server isn't running early in the AM??

TIA  Art.

Try:  http://www.angelfire.com/in2/ontkoi/X10AHP/X10WavPlayerV1.3.zip
Logged
-Bill- (of wgjohns.com)
bill@wgjohns.com

In the real world, the only constant is change.

When I'm online you can find me in the Home Automation Chat Room!

JimC

  • Hero Member
  • *****
  • Helpful Post Rating: 41
  • Posts: 631
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #21 on: October 29, 2006, 06:12:26 AM »

Bill,

Just wanted to let you know that your software is a blast. I have been playing around with it ,on and off, ever since Tuicemen was nice enough to post the link to it in these forums a year or so ago. Every update seems to only make it better. Having downloaded every update I only once had problems and it was, OF COURSE, my own doing. A message to you got it quickly straitened out. THANKYOU  ;D :D ;)

Quote from: Bill- (of BXVC)
I beg your pardon for publicly venting my spleen at Dan!


I, for one , thought you showed great restraint in dealing with this situation and again making him a happy camper.

Jim
Logged
_ _ ...  ..._ _

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 272
  • Posts: 10109
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #22 on: October 29, 2006, 04:02:54 PM »

Wow! I go away for the week end and everything explodes! ::) ;) :D :)
Thanks for everyones praise of X0WavPlayer!
Even yours Dan! ;) :D
I wonder what I'll miss when I go away for a weeks Hunt! ??? ::) ;)
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 272
  • Posts: 10109
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #23 on: October 29, 2006, 07:06:07 PM »

Tuicemen  made a nice little program, but "freeware" that makes people do what they don't really want to isn't worth it.
Just incase someone else feels this way!
Warning:
  • X10WavPlayer Must be run from the PC
  • The PC must be turned ON
  • The CM15A Must be connected to the PC
  • You Need PC speakers the CM15A doesn't have any!
  • AHP must be running!
  • Macros which trigger the X10Wavplayer must be run from the PC
[/color][/b]
 I hope I didn't forget something! I'd hate to create something that made someone do what they didn't want to! ;) :D
If your leary about exactly what this will do or won't do just Ask!
OH! And you can PM me, I do answer them! ;) :D ;D
Dan: If I was charging for this would that have made it worth it? ::) ???
« Last Edit: October 29, 2006, 07:07:45 PM by Tuicemen »
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Dan Lawrence

  • Hero Member
  • *****
  • Helpful Post Rating: 68
  • Posts: 3991
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #24 on: October 29, 2006, 10:14:53 PM »

With your red Warning!!! list, probably not.  When I downloaded it, it was very well done and the player itself worked fine.  It was when I found the macros had to be run from the PC as opposed to the CM15A, that's when I decided to delete it.  I use AHP to control lights in the house and have a single macro that turns all the lights on 3 housecodes off at the press of A5 off. AHP does what I want it to do.

That's why I'm not interested in any of the plug-ins for AHP. Don't need any.

Thank you for your work on it.

Logged
I don't SELL this stuff... BUT I sure do ENJOY using it!!!

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 272
  • Posts: 10109
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #25 on: October 30, 2006, 09:13:51 AM »

As of yet NO Thirdparty software or add-on can download to the CM15A! :( ::) ;)
That may change down the road with a SDK update, but I wouldn't hold my breath! ;) :D :)
If it ever does happen I'll let you know Dan.
Quote from: Dan Lawerence
Thank you for your work on it.
Your welcome Dan! Sorry it didn't work the way you wished it to! ;) :D
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

-Bill- (of wgjohns.com)

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 81
  • Posts: 1340
  • He's just this guy. You know?
    • wgjohns.com
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #26 on: October 31, 2006, 12:12:20 AM »

Obviously, the obvious is not always obvious.   ;) ???

Otherwise, I wouldn't have had the fun of musing about the instructions on a prescription pill bottle this weekend.

The instructions stated; "Take one tablet daily by mouth."  and I thought; "Isn't that (by mouth) obvious?  Where else would you put it? ??? ::) :o"  then I thought; "Do they feel they have to specify, because someone got it... wrong?!!   ??? :-[ :o"

P.S.
This message is meant to be read by eye, text-to-speech reader or braille reader, etc.  It is not meant to be taken orally, or inserted in any other orifice!  Unless you really want to, in which case the author can not be held responsible for the outcome.

 ;D
Logged
-Bill- (of wgjohns.com)
bill@wgjohns.com

In the real world, the only constant is change.

When I'm online you can find me in the Home Automation Chat Room!

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 272
  • Posts: 10109
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #27 on: November 23, 2006, 06:00:18 PM »

I just posted An update to X10wavPlayer

Version 1.4 adds codding to stop x10Wavplayer from opening multiple copies of its self!

This should help when using it with X10dispatchers Flood detection or save a flag for some! ;)
(I know you have few of these left Puck)

The link is still the same X10Wavplayer ;)
« Last Edit: November 23, 2006, 06:03:41 PM by Tuicemen »
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 272
  • Posts: 10109
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #28 on: November 28, 2006, 12:10:44 AM »

***New version 1.5***
Fixed  bug:
When restarting Active Home Pro, x10wavplayer created batch files would no longer execute!

This should have fixed the problem of files stopped working after a period of time as well!
if not let me know! ;) :D

If you have x10wavplayer created batch files you'll need to recreate them! ::) :-[ ;)

Sorry

No added gadjets  :-[ :(
Can't think of every thing myself! ;) :D ;D

If you notice any other problems or wish for an option please PM me  ;) :D
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 272
  • Posts: 10109
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: [Add-On] X10WavPlayer (Add Sound)
« Reply #29 on: November 29, 2006, 01:43:31 PM »

I've now created an Installer for X10WavPlayer .

However Anglefire won't permit downloading of exe files :'( ::) ;)

So you must rename the download to X10WavPlayer.exe

Once it is renamed just open it and follow the on screen prompts! ;) :D

Hope this helps those Having troubles or confused with zip files ;) :D
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum
Pages: 1 [2] 3 4 ... 10
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.