Please login or register.

Login with username, password and session length
Advanced search  


Author Topic: I agree......18 months of crap....THIS SOFTWARE SUCKS!!!!!!!  (Read 5381 times)


  • Newbie
  • Helpful Post Rating: -1
  • Posts: 2
I agree......18 months of crap....THIS SOFTWARE SUCKS!!!!!!!
« on: February 04, 2007, 03:56:50 PM »

Bought AHPro, iWitness, cameras & SmartMacros in July of 2004, 18 months of total F******! aggravation. Cannot keep spot lights off during the day, and most of the time every F******!! light that IS NOT in a macro or timer is on when the motion sensor triggers the SINGLE F******!! macro I have running. BUGS< BUGS< AND NORE BUGS in the F******!! software that I have called and talked with Tom Monroe (not at X10 any longer), Tony McCarl (Big GURU), Dustin B. (some kind of F******!! manager, and SOOOOOOOOOO many tech reps that I cannot keep track of, and carboned copied most of the emails to "president" of X10 WITHOUT EVER GETTING ONE BACK from him or her!!!!!! We have a file folder over one inch thick of BUGS, **** that happens or DOESN'T happen, etc., etc., etc!!!! You would think that X10 would want to hear about issues SO THEY COULD MAKE THEIR PRODUCT PERFORM BETTER.?????????I have been using X10 products since the early '80s, back when the VIC 20 and the Commodore 64 was the rage, went to Active Home and things worked very well. But with this F******!! AHPro and the F******!! plugins that do not even seem like they "mesh" together. Tech support SUCKS, they got my $MONEY$ and I have a product that aggravates the F*** of of me and the wife EVERY F******!! day!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I WANT MY F******!! $MONEY$ BACK!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I wish there was a third party who has software that WORKS, anyone know of such a product or company, PLEASE let us know at

dave w

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 138
  • Posts: 6109
Re: I agree......18 months of crap....THIS SOFTWARE SUCKS!!!!!!!
« Reply #1 on: February 05, 2007, 01:01:05 PM »

You seem to be having more problems than most. Are you sure you are not having noise or neighbor problems?

Homeseer 2.xx is very good home control software, but considerably more expensive than AHP. Homeseer can use your old CM11A as the software to PLC interface.
"This aftershave makes me look fat"


  • Jr. Member
  • **
  • Helpful Post Rating: 0
  • Posts: 11
Re: I agree......18 months of crap....THIS SOFTWARE SUCKS!!!!!!!
« Reply #2 on: June 09, 2007, 05:11:06 PM »


   I am new to AHP also (about 6 weeks) and have spent practically every waken minute trying (unsuccessfully I might add) to get AHP with SMART MACROS, MYHOME setup and running halfway right.

   I have a high caliber dedicated computer running XP Pro (a Dell 1.6ghz processor w/ 1.2 Gigs ram, 80 gig HD, UPS) connected to broadband internet via a D-link 4 port router.   The X-10 system consists of a USB interface, three cameras on house code "C", two ninja pan-tilt bases, five motion sensors on house code "A", nine x-10 modules on house code "B", a palm pad, and a couple of three button switch plates, and a 2 phase powerline coupler/filter.      This is all installed in a small lakehouse (about 900 sq ft) in a remote location with little - to no powerline or RF interference.

   First the CM15A (out of the box) has such a sorry range nothing would work more than 20' (even though advertising leads you to believe 100').     Finally - after much frustration and reading of this forum - I found where users were modifying the antenna [see Project to Increase Range].     What a sorry state of affairs when you buy several hundred dollars worth of stuff -- not to mention the value of the dedicated computer system to run it, and you find out you have to modify the manufacturer's gear to get it to even get close to their OWN specs.

   By modifying the antenna (and forfeiting the CM15A warranty) and locating it in the center of the house, and running a LONG USB cable to the computer,  I did get all the x-10 modules to work correctly with the palm pad.   But the USB cable is too long, causing frequent errors with the PC communicating with the interface.     To get the three wireless cameras to work, I had to locate the video receiver in the center of the house and run a LONG shielded RCA cable to the USB video adapter and fight with my wireless router frequency for about a week.    (Incidentally, in this small house, NOTHING is now more than 35 feet from the CM15A or the video receiver  -- It oughta work great if X10's advertising wasn't totally fraudulent.)

    I finally got the cameras and x-10 stuff all working quiet acceptably when operated individually from switch plates,  palm pad and pan-tilt remotes.     BUT all the software is a whole nuther story!!!!     MYHOUSE is total CRAP!     It either is so unreliable it's worthless, or just plain DON'T work.      The video (though it says "video connected") displays only a blue panel at least 98 times out of 100 attempts to remotely connect.    That is if it even connects with MYHOUSE.COM.  Most of the time it goes into a stupid loop connecting and disconnecting.    I called NOSUPPORT and got some half-baked tech that insisted I had to deinstall and reinstall MYHOUSE.      I'm no idiot!!!     Having dealt with computers at ALL levels for an entire career lifetime, something that randomly works correctly once or twice out of twenty attempts doesn't need to be deinstalled and reinstalled.     It needs to be FIXED!!

    To make matters worse, NO tech has yet told me what ports or services must be allowed through the firewall or router.      I don't think they know!    How many users today have a single computer with a fixed IP address setting in the DMZ?    You get back of that (behind a router running NAT or a corporate firewall) you have to know WHAT services are being used.    I think I have figured out you have to allow ports 8000 to 9000 to get MYHOUSE to even connect --- But I still don't get video reliably.    I have disabled the firewall at headquarters and opened ALL ports on the router at the remote (AHP) site, and MYHOUSE still won't connect more than .005% of the time!    Like I said, it's CRAP.    I can use "Remote Terminal" and view my live and stored video, but I paid for Worldwide Internet Access --- and somebody better start telling me how to get it to work from ANYWHERE IN THE WORLD like the advertising or X-10 is going to have themselves a class action lawsuit on their hands.   And I will be using this forum to look for class members to join as additional plaintiff's.     Perhaps if about 100,000 customers all wanted their $49.00 back via a good ole class action lawsuit somebody would take the NOSUPPORT calls more seriously.

    Now as for SMART MACROS!!!  It's more like DUMBASS MACROS.   How smart is it for a MACRO to load MULTIPLE COPIES of itself an unlimited number of times until you overrun the stack or overflow 1.2 gig's of ram with hundreds of copies of several macros running?   HELL YES that will cause ERATIC CONTROL.      About the time a timer in one copy of the MACRO expires and turns a light off, another copy of the damn MACRO turns it right back ON.     WHAT??? No programmer at X-10 ever heard of re-entrant programs??     Of course who would likely want "re-entrant" MACROS tied to a motion detector capable of sending bunches of ON commands????
     OH, -- you say use "FLAGS".    Well, that would just be great, but the damn FLAGS do not work either.   I tried to set a flag on MACRO entry and clear it on MACRO completion -- then conditionally triggering the MACRO on that flag.   But the "Conditions" in the MACRO DESIGNER don't work either.   I haven't figured out WHY yet, but I suspect multiple copies of the flag word is allowed to be loaded into memory in the same fashion as the MACROS.    Or the X10 programmers dont know whether true results in a data "1" or data "0". 
     OH, another thing, I just PROVED this evening that MACROS continue to run and actuate modules AFTER clearing the memory in the CM15A, ---- AND  ---- exiting AHP.      This sounds so ridiculous that I can hardly write it.    But I verified FOUR SEPARATE occurrences of MACRO functions actuating X-10 modules after clearing memory in the CM15A and exiting ActiveHome Pro completely to the desktop.     I am convinced AHP exits without stopping the SMART MACRO addon.    When I powered the PC completely OFF, the X-10 modules ceased to react to MACROS triggered by their referenced motion detectors.    (Like I said -- DUMBASS MACROS!!)

    Oh there is MORE.    Like AHP crashing and reporting "it has to close  -- sorry for the inconvenience".   And the MACRO LIBRARY.     Why don't somebody tell me where the library is?       This has probably gotten TOO LONG and written in a state of TOO MUCH frustration to get a response from anybody, but as I said earlier, X-10 happily took my money and shipped a bunch of stuff under some pretty elaborate claims that haven't even nearly proven to be true and that is not a good move with me.    I've spent about all the manpower I intend to spend trying to find "workarounds" or avoid "quirks" or navigate through "bugs".     Somebody better start answering some of my questions or my current attitude is the forum needs to be changed to something much more likely to get some attention.

Logged | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 All rights reserved.