Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Pages: [1] 2

Author Topic: mystery module comes and goes  (Read 10822 times)

EL34

  • Hero Member
  • *****
  • Helpful Post Rating: 21
  • Posts: 278
    • My X-10 projects
mystery module comes and goes
« on: June 03, 2008, 06:54:35 AM »

I watch the X10 traffic on my system and see that there is a g7 module that gets turned on now and then.

I don't have a g7 module showing in AHP, but I think I did a year or so ago.

I have unplugged the cm15 and removed the batteries, but the g7 module still rides the power lines.
It's like a ghost that refuses to die.  >*<


Anyone ever have any ghost modules and how can I get rid of it?
Logged
W10 - CM15A - AHP 3.301 - i Witness - MyHouse online - Smart Macros - SDK using Visual Basic express 2008
My X10 page-> http://www.el34world.com/Misc/home/X10_0.htm

-Bill- (of wgjohns.com)

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 81
  • Posts: 1340
  • He's just this guy. You know?
    • wgjohns.com
Re: mystery module comes and goes
« Reply #1 on: June 03, 2008, 10:29:51 PM »

I watch the X10 traffic on my system and see that there is a g7 module that gets turned on now and then.

I don't have a g7 module showing in AHP, but I think I did a year or so ago.

I have unplugged the cm15 and removed the batteries, but the g7 module still rides the power lines.
It's like a ghost that refuses to die.  >*<


Anyone ever have any ghost modules and how can I get rid of it?


Does it always show up, or only when you use RF controllers / motions ?
Logged
-Bill- (of wgjohns.com)
bill@wgjohns.com

In the real world, the only constant is change.

When I'm online you can find me in the Home Automation Chat Room!

Puck

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 171
  • Posts: 1799
Re: mystery module comes and goes
« Reply #2 on: June 04, 2008, 08:57:22 AM »

EL34: I'm sure are aware of some motion sensor's UC+1 when it transitions between light & dark, so I just wanted to add that possibility here for others who may have the same question but are unaware of this feature.
Logged

EL34

  • Hero Member
  • *****
  • Helpful Post Rating: 21
  • Posts: 278
    • My X-10 projects
Re: mystery module comes and goes
« Reply #3 on: June 04, 2008, 09:56:31 AM »

Bill, It's kind of random, at least I haven't noticed any patterns, but I'll start taking notes and see if there is an opaque pattern.

Puck, I don't have any X10 motion sensors outside. I only have one of the small ones in a shop dust room, but it is not able to see sunlight. There are a couple windows in that room, but they face away from the sun and are on a shady side of the building. I'll keep an eye out for time of day patterns.

I use the motion sensors you see on this page, coupled to powerflash units.
http://www.el34world.com/Misc/home/X10_2.htm

Thanks for the tips guys, I'll keep a closer watch on things.
Logged
W10 - CM15A - AHP 3.301 - i Witness - MyHouse online - Smart Macros - SDK using Visual Basic express 2008
My X10 page-> http://www.el34world.com/Misc/home/X10_0.htm

steven r

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 74
  • Posts: 2189
  • Halloween with X10
Re: mystery module comes and goes
« Reply #4 on: June 04, 2008, 10:20:17 AM »

...I don't have a g7 module showing in AHP, but I think I did a year or so ago....
I think I recall having a similar problem once when a module that I had deleted but not emptied from the recycle bin came back to haunt me. It's been awhile so I may not be remembering the details. View your deleted bin and if there is anything in it, particularly a G7 module, empty the bin and try re downloading. Maybe even clearing the CM15A and reloading again.
Logged
BVC let's me tell my camera where to go!
:) Murphy is my beta testing pal. He helps me find problems whether I like it or not. :)

Puck

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 171
  • Posts: 1799
Re: mystery module comes and goes
« Reply #5 on: June 04, 2008, 10:58:46 AM »

EL34: What color does G7 appear as?

I believe the colors are appointed this way:

Green: A physical module is defined in your AHX file.

Yellow: No physical module, but the address is called from somewhere in your AHX file (a macro).

Red: Address received from another source (PLC or RF) and not from your AHX file.

If it's Yellow and you can't find it in a macro anywhere, then it's probably as steven r suggested.
Logged

EL34

  • Hero Member
  • *****
  • Helpful Post Rating: 21
  • Posts: 278
    • My X-10 projects
Re: mystery module comes and goes
« Reply #6 on: June 04, 2008, 12:46:18 PM »

I'm not using AHP any more, it not even loaded and running, but I do remember seeing g7 pop up in the AHP log file also when I did use AHP.

I am using my Custom VB program to view X10 traffic
http://www.el34world.com/Misc/home/X10_5.htm

I will fire up AHP again and check the recycle bin.

I do remember a while back, adding a g7 mdule to AHP and then deleteing it, but it still showed up in AHP traffic now and then. I set a appliance module to g7 and plugged it in, it ccame on by itself when the ghost g7 appeared on the X10 network.
Logged
W10 - CM15A - AHP 3.301 - i Witness - MyHouse online - Smart Macros - SDK using Visual Basic express 2008
My X10 page-> http://www.el34world.com/Misc/home/X10_0.htm

EL34

  • Hero Member
  • *****
  • Helpful Post Rating: 21
  • Posts: 278
    • My X-10 projects
Re: mystery module comes and goes
« Reply #7 on: June 04, 2008, 01:15:25 PM »

Ok, I looked back at my X10 traffic monitor and found this pattern for g7
I reset the monitor every couple days so I could only find these four entries for the last two days.

20:24:56-recvplc-g7-On
06:59:07-recvplc-g7-Off

20:29:41-recvplc-g7-On
06:53:25-recvplc-g7-Off

It's like the module is on some sort of timer, but it's not dusk and dawn.

dusk and dawn the last couple days here were
dusk is 20:42
dawn is 6:13

I looked inside my .ahx file and do not see any occurances of g7
Logged
W10 - CM15A - AHP 3.301 - i Witness - MyHouse online - Smart Macros - SDK using Visual Basic express 2008
My X10 page-> http://www.el34world.com/Misc/home/X10_0.htm

steven r

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 74
  • Posts: 2189
  • Halloween with X10
Re: mystery module comes and goes
« Reply #8 on: June 04, 2008, 03:31:47 PM »

...I don't have a g7 module showing in AHP, but I think I did a year or so ago.
I have unplugged the cm15 and removed the batteries, but the g7 module still rides the power lines.

I'm not using AHP any more, it not even loaded and running, but I do remember seeing g7 pop up in the AHP log file also when I did use AHP.

I am using my Custom VB program to view X10 traffic
http://www.el34world.com/Misc/home/X10_5.htm

I will fire up AHP again and check the recycle bin....
To clear things up for me anyway, you're not using AHP but you are still using the CM15A with your program, right?
Do you still need AHP to setup modules and macros for the CM15A or is your program handling that?
Does your custom program only view or can it issue commands also?
Let us know what, if anything, you find in the recycle bin.
The use of a 3rd party program adds a variable to problem that most, if not all of us, here are not familiar. It might help to back step for a day and see if the problem continues if you are using just AHP.
Logged
BVC let's me tell my camera where to go!
:) Murphy is my beta testing pal. He helps me find problems whether I like it or not. :)

Puck

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 171
  • Posts: 1799
Re: mystery module comes and goes
« Reply #9 on: June 04, 2008, 06:30:27 PM »

20:24:56-recvplc-g7-On
06:59:07-recvplc-g7-Off

20:29:41-recvplc-g7-On
06:53:25-recvplc-g7-Off

Do you have an old forgotten about X10 motion sensor laying on a shelf somewhere? Those times sure look like when it would start seeing dark & light and sending out a UC+1 signal. Especially with the ON at dark & the OFF at light.

With it changing daily and being close but not at the CM15A's dusk/dawn, it doesn't sound like a timer or macro.
Logged

EL34

  • Hero Member
  • *****
  • Helpful Post Rating: 21
  • Posts: 278
    • My X-10 projects
Re: mystery module comes and goes
« Reply #10 on: June 06, 2008, 06:38:17 PM »

Steven,
I don't use AHP, I am using my own custom program with the SDK with the cm15a

The mystery module appears in the AHP activity monitor also.

yes, when I install a new module, I start AHP and set it up there and save the config file.

My program does many things, it does just about everything AHP does.
More info here - http://www.el34world.com/Misc/home/X10_5.htm

recycle bin is empty in AHP

Puck, I don't have any x10 motion sensors, just one eagle eye that was described above. I have never purchased or used any x10 motion sensors except the eagle eye.

The g7 module is still showing up in my x10 traffic.

I am probably gonna get another cm15a for my girlfriends house.
I'll use the fresh one here and give her my old one to see what happens.

The g7 module has to be stuck inside the cm15a, I don't see how else the thing can get onto the x10 traffic.
If you think about it, look at your AHP Find other computers and see how many other modules you do not have installed show up in that screen.
That screen always registers other modules until you reset the log file.
« Last Edit: June 06, 2008, 06:42:13 PM by EL34 »
Logged
W10 - CM15A - AHP 3.301 - i Witness - MyHouse online - Smart Macros - SDK using Visual Basic express 2008
My X10 page-> http://www.el34world.com/Misc/home/X10_0.htm

steven r

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 74
  • Posts: 2189
  • Halloween with X10
Re: mystery module comes and goes
« Reply #11 on: June 06, 2008, 08:57:29 PM »

...I don't have any x10 motion sensors, just one eagle eye that was described above. I have never purchased or used any x10 motion sensors except the eagle eye....
What is the the current address of the eagle eye you have and where is it placed?

...I am probably gonna get another cm15a for my girlfriends house.
I'll use the fresh one here and give her my old one to see what happens....
I will be interested to see if the problem moves to her house. My bet is that it doesn't but either way it will serve to help isolate the problem.
Let us know.
Logged
BVC let's me tell my camera where to go!
:) Murphy is my beta testing pal. He helps me find problems whether I like it or not. :)

EL34

  • Hero Member
  • *****
  • Helpful Post Rating: 21
  • Posts: 278
    • My X-10 projects
Re: mystery module comes and goes
« Reply #12 on: June 07, 2008, 06:29:18 AM »

Yeah me too, I'll post back when I get another cm15a .

The reason I was thinking it was the cm15a is that it shows up in my x10 traffic every evening after 8pm like it's and old timer or something

two more entries for the last two days
06-05-2008 - 20:18:37 - recvplc - g7 - On
06-06-2008 - 20:20:34 - recvplc - g7 - On

It's like it's on a timer, but at no exact set time.

I'll check the eagle eye motion sensor and see what it is set to, can't remember right now, and it is in another building.
It is inside a shop dust room. when I walk into the room, the eagle eye turns on a appliance module that then turns on two exhaust fans.

so according to what puck said, the motion sensor can do this sort of thing?
« Last Edit: June 07, 2008, 06:31:00 AM by EL34 »
Logged
W10 - CM15A - AHP 3.301 - i Witness - MyHouse online - Smart Macros - SDK using Visual Basic express 2008
My X10 page-> http://www.el34world.com/Misc/home/X10_0.htm

steven r

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 74
  • Posts: 2189
  • Halloween with X10
Re: mystery module comes and goes
« Reply #13 on: June 07, 2008, 07:02:58 AM »

To sum up... (Pardon me stepping in Puck.)

20:24:56-recvplc-g7-On
06:59:07-recvplc-g7-Off

20:29:41-recvplc-g7-On
06:53:25-recvplc-g7-Off
...Those times sure look like when it would start seeing dark & light and sending out a UC+1 signal. Especially with the ON at dark & the OFF at light....

...so according to what puck said, the motion sensor can do this sort of thing?
If it turns out that your eagle eye UC is set for G6 then it's will send a G7 (UC+1) ON when it senses dark and and a G7 OFF when it senses light.
Logged
BVC let's me tell my camera where to go!
:) Murphy is my beta testing pal. He helps me find problems whether I like it or not. :)

EL34

  • Hero Member
  • *****
  • Helpful Post Rating: 21
  • Posts: 278
    • My X-10 projects
Re: mystery module comes and goes
« Reply #14 on: June 07, 2008, 01:15:10 PM »

Ahhha, really?

I just checked and the eagle eye is set to G6.
G6 is the wall socket module that the dust fans are plugged into.

The Eagle eye sends a rf signal to a nearby TF751.
The TF751 send plc command to G6 wall socket.

Crap, so what would happen if I used G16 on the eagle eye and the wall receptacle?
There is no G17

Now I see what you are saying about the motion sensors.
wasn't really sure what UC+1 meant.

Still not sure what UC is?  rofl
Logged
W10 - CM15A - AHP 3.301 - i Witness - MyHouse online - Smart Macros - SDK using Visual Basic express 2008
My X10 page-> http://www.el34world.com/Misc/home/X10_0.htm
Pages: [1] 2
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.