Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: No sound from speakers on ps561  (Read 3327 times)

dogs621

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 4
No sound from speakers on ps561
« on: December 19, 2009, 12:54:49 PM »

What would cause the siren/speakers to not sound on the ps 561 base when panic is pressed on the remote?  You can hear a very very faint attempt if you put the whole unit up to your ear!  yes, the small switch on the back is set to tone and the system "armed" light is functioning.  Any suggestions would be welcomed...... ???
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 289
  • Posts: 12698
Re: No sound from speakers on ps561
« Reply #1 on: December 19, 2009, 01:48:35 PM »

Maybe defective. Does the sounder ever emit any sounds?
Logged

dogs621

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 4
Re: No sound from speakers on ps561
« Reply #2 on: December 23, 2009, 11:13:34 AM »

No.  I think it must be defective.  I assume it would work normally otherwise if I buy the powerhorn.
Thanks
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 289
  • Posts: 12698
Re: No sound from speakers on ps561
« Reply #3 on: December 23, 2009, 11:22:30 AM »

You may want to call x10 support as it sounds like it is defective. A warranty replacement maybe in order.
The PH508 Powerhorn will only sound during an alarm and not give you any of the other sounds like open door.
Also some are reporting the later Powerhorns and the newer security panels act different. The Powerhorn only sounds for six seconds then stops.
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.