Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: XTBR Status (enhanced repeater version of the XTB)  (Read 8464 times)

JeffVolp

  • Moderator
  • Hero Member
  • *
  • Helpful Post Rating: 106
  • Posts: 2058
    • XTB Home Page
XTBR Status (enhanced repeater version of the XTB)
« on: November 13, 2009, 09:48:00 AM »


A number of people have asked about the status of the XTBR enhanced repeater version of the XTB.  I had hoped to be shipping that unit by now, but there is still one issue to resolve.  Those that were out in the field with the beta testers have worked fine, so I thought the unit was pretty much good to go.  However, I did run across three issues in the production unit.  Two of them have been resolved, and I am working the last one now.

One issue concerned the 120KHz bandpass filter.  Using 5% tolerance capacitors was not sufficient to keep the filter centered on the X10 passband, and I am trimming units now by adjusting the 1% resistor values.  The next kitting cycle will use more expensive 1% tolerance capacitors so no trim will be necessary.

The second issue concerns the return signal amplifier itself.  Initially I had used the cost effective LM318 that is used in the XTB.  With that op-amp driving the additional circuitry, it exhibited some distortion at higher signal levels.  The distortion was eliminated by changing to the much more expensive Analog Devices AD817 used in the big brother XTB-IIR.

The remaining problem concerns the AGC loop.  A stream of continuous commands from a Maxi Controller can cause the AGC threshold level to gradually increase.  After 10 to 20 seconds, the AGC threshold reaches the incoming signal level, causing it to be ignored.  This happens almost at the command storm shutdown point, so it is unlikely this will ever be seen during normal operation.   And, any interruption in the incoming command stream immediately returns the AGC threshold to the background noise level.  I hope to have this remaining issue resolved soon.

UPDATE:  Well that was easy.  It turned out the XTBR was interfering with itself.  The powerful output was causing additional zero crossing interrupts, skewing the time reference so the AGC sample window just caught the beginning of a transmission.  Masking the interrupt during the transmission resolved the problem.

Replacement units should go out to the prior beta testers early next week.  After that, the unit will be ready for normal distribution.

Jeff
« Last Edit: November 13, 2009, 12:32:15 PM by JeffVolp »
Logged
X-10 automation since the BSR days

JeffVolp

  • Moderator
  • Hero Member
  • *
  • Helpful Post Rating: 106
  • Posts: 2058
    • XTB Home Page
Re: XTBR Status (enhanced repeater version of the XTB)
« Reply #1 on: December 03, 2009, 06:22:28 PM »

The beta testers all have the "production" version of the XTBR.  So far they are working exactly as they should.  I uploaded a high-resolution photo of a partly assembled PCB.  The transformer and big electrolytic capacitor that occupy most of the board were left off so all the other components are visible:

http://jvde.us/xtb/XTBR_pcb_v10.jpg

Here is a completed board:

http://jvde.us/xtb/XTBR_assembled.jpg

And the board installed in the base:

http://jvde.us/xtb/XTBR_open.jpg

The remainder of the documentation will be filled in as I have time.

Jeff
« Last Edit: December 30, 2009, 04:06:40 PM by JeffVolp »
Logged
X-10 automation since the BSR days
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.