Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Author Topic: CM-15A Fails when detached from Computer  (Read 3063 times)

AldeBaran

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 2
CM-15A Fails when detached from Computer
« on: May 23, 2010, 10:46:13 PM »

Hi,

If this issue has been previously answered, please accept my apologies and direct me to the appropriate post(s).  My CM-15A ActiveHome Interface is a couple of months old [manufacturing code: 09J41].  I have never tried running it free-standing until today, but I am not having any luck now in doing so.  If I run or trigger a macro with the ActiveHome software open, the sequence is followed and I graphically see what is happening.  If I CLOSE ActiveHome but leave the USB cable attached to the computer, the sequence still runs flawlessly.   Now it gets weird!!!

If I DISCONNECT the USB cable OR turn off the computer [even though ActiveHome has been closed], the sequence stops.  If I pull out the USB cable in the middle of a sequence (triggered Macro event), the sequence stops.

What is a live USB port connection providing the CM-15A that it can not operate without?  I have replaced the batteries (and reset the interface), cleared the interface memory from the open ActiveHome software, and tried an entirely new and previously unused CM-15A interface, all to no avail.

My computer is a 32-bit Vista system and the software runs fine when it is open.  I just can not figure out the ghost in this machine and what is so.  I have my CM-15A and the two modules that are triggered by the DS10A all plugged into a single power strip.  Is this a software issue and, if so, how can I clear out the current software and re-install an earlier release?  If this is a "stupid user error" please be gentle, but firm in helping me to understand where I am failing.

I appreciate and give thanks, in advance, for the time and interest expressed in responses to this post from those more knowledgeable than I.

Regards - Baran
Logged

paizano1

  • Sr. Member
  • ****
  • Helpful Post Rating: 13
  • Posts: 98
Re: CM-15A Fails when detached from Computer
« Reply #1 on: May 23, 2010, 11:44:36 PM »

All macros need to be executed from the PC.
Logged

-Bill- (of wgjohns.com)

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 81
  • Posts: 1340
  • He's just this guy. You know?
    • wgjohns.com
Re: CM-15A Fails when detached from Computer
« Reply #2 on: May 24, 2010, 02:38:48 AM »

AldeBaran,

Yes, as paizano1 stated, but with a little clarification, any macros involving X10 security sensors like the DS10A require the PC to be running and connected to the CM15A.

The CM15A isn't smart enough to talk to the security sensors on its own.

 >!
Logged
-Bill- (of wgjohns.com)
bill@wgjohns.com

In the real world, the only constant is change.

When I'm online you can find me in the Home Automation Chat Room!

AldeBaran

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 2
Re: CM-15A Fails when detached from Computer
« Reply #3 on: May 24, 2010, 04:24:30 PM »

Well Shut My USB Port,

Thanks for that information.  I was led to believe that the CM-15A was totally stand alone, unless one needed memory to record images or video.   I guess that is something for the wishlist, eh?  Throw a couple of gig of memory under the CM-15A hood and give it the freedom it diserves.

Much Appreciation - Baran
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.