Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1] 2

Author Topic: Windows 7 PC and VA12A 64-bit drivers  (Read 31240 times)

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Windows 7 PC and VA12A 64-bit drivers
« on: August 28, 2010, 07:04:18 PM »

Has anyone been successful in viewing their wireless X10 cameras using a Windows 7 64-bit PC?  I've been successful using a previous XP PC and I'm successful in viewing my cameras via a TV.  So I know my setup works. But I have not been successful in viewing my cameras via my Windows 7 PC.  When I plug in my VA12A it doesn't load the drivers.  Can someone help with this issue?  X10 level 2 support seems to be stumpted 
Logged

Dr.Fiero

  • Full Member
  • ***
  • Helpful Post Rating: 7
  • Posts: 71
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #1 on: August 28, 2010, 10:20:29 PM »

That's what I'm using - no problems. 

It's been long enough now that I don't remember the precise sequence used, but...  it wasn't that hard.

I seem to recall plugging in the device.  It fails to load drivers (of course).
Went into device manager, found the failed device.
Bring up the manual driver loading option, pointed to the folder, and let it load.
Restarted.

Seems to work!
Logged

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #2 on: August 29, 2010, 12:57:52 AM »

Dr.Fiero -- Not sure if this is what you were referring to or not (see below).  But I haven't been able to make this work either.

C:\Program Files (x86)\Common Files\X10\DriverInstall\VA12A Video Capture\Vista64
Logged

Dr.Fiero

  • Full Member
  • ***
  • Helpful Post Rating: 7
  • Posts: 71
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #3 on: August 29, 2010, 10:48:39 AM »

Did you grab the drivers, and the info from this page?
http://kbase.x10.com/wiki/VA12A_Driver_Load_Procedure
Logged

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #4 on: August 29, 2010, 12:26:19 PM »

Yes, I've done that too.  After following those instructions I get the message "Windows found driver software for your device but encountered an error while attempting to install it  -- X10 VA12A Video Capture -- Driver is not intended for this platform ."
Logged

Dr.Fiero

  • Full Member
  • ***
  • Helpful Post Rating: 7
  • Posts: 71
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #5 on: August 29, 2010, 01:44:57 PM »

Not sure what to tell ya here...

Under properties, I'm showing: Version 2.87.0.33

Are you plugged into a hub by chance?  Try straight into a 2.0 port if so.
Logged

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #6 on: August 29, 2010, 09:26:25 PM »

Sorry, but what are you referring to (an application, driver, etc.) when you say Version  2.87.0.33?  And to answer your question ... I've connected the VA12A directly into Port 2
Logged

Dr.Fiero

  • Full Member
  • ***
  • Helpful Post Rating: 7
  • Posts: 71
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #7 on: August 30, 2010, 10:28:29 AM »

In reference to the installed driver version.
Logged

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #8 on: August 30, 2010, 12:28:52 PM »

Thanks Dr.Fiero ... that's the same version number I have on the installed driver.  I'm beginning to think that the VA12A may be defective.  Although this is the second one that I've received.  And my system (PC) does recognize the device as a VA12A device.  So that kind of tells me the VA12A may not be defective. 

Some directory path is broken somewhere that prevents the software being loaded properly (a guess on my part).  This is the path where the driver is being loaded on my PC (C:\Program Files (x86)\X10 Hardware).  Within that directory is a folder with a text document call INSTALL and two Internet shortcuts (X10 Hardware Setup Help and X10).  If I open the INSTALL document it looks like program code and is Titled: X10 Hardware (TM) Setup.

Dr.Fiero, if you have this file would you send me a copy (see my profile for email address).  I would like to compare it to my file.  Thanks.
Logged

Dr.Fiero

  • Full Member
  • ***
  • Helpful Post Rating: 7
  • Posts: 71
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #9 on: August 30, 2010, 06:53:54 PM »

You evidently have extensions turned off - the file is called 'install.log'

Anyhow, it's just a record of what got installed in the registry, etc.
I'll send you a copy if you like - but I don't think it'll help much.
Logged

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #10 on: August 31, 2010, 11:04:30 AM »

Dr.Fiero -- thank you for the copy of your INSTALL.log.  Actually the file helped me a lot.  There are some subtle differences in your log when I compare it to my log.  These I don't understand yet ... but I will eventually.  At the very least the log shows the x10drivers executable is completing the install.  And that's what I wanted to know initially.  So comparing it to your log confirms that.

What I need to learn now is, what is supposed to happen when I connect the VA12A.   
Logged

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 11
  • Posts: 756
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #11 on: September 01, 2010, 08:21:49 PM »

dont want to burst ur bubble, but search these forums for past posts on va12 and win7.

I personally did complete testing on va11 & va12 on win7 32bit & win7 64bit machines here.

va11 works with both.

va12 works with win7 32bit and NOT win7 64bit.  the drive is not compatable with win7 64bit.  period.  lots of supposed do this do that stuff stated but in the end there is no win7 64bit driver that will work with the va12.

do as I did;  buy a va11 and go on.

BUY A VA11 AND GO ON IS A TYPO - SHUUD HAVE BEEN BUY A VA12 AND GO ON.  VA11 WONT WORK WITH WIN7 64BIT/ PERIOD.  VA12 DOES WITH VER 2.236 AHP no special drivers
« Last Edit: September 14, 2010, 08:45:57 PM by mike »
Logged

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #12 on: September 02, 2010, 10:50:14 AM »

Mike -- interesting comments.

I have a VA11A that worked fine with my XP PC, but does not work with my Windows 7 64-bit PC.  Nor does the VA12A work with my Windows 7 64-bit PC.  But looking at Dr.Fiero's comments his VA12A works fine for him 

I have a couple of questions regarding your testing.  Did you use the same driver download file from http://software.x10.com/pub/applications/drivers/x10drivers.exe for your VA11A and VA12A testing?  And the VA11A worked fine for your Windows 7 64-bit PC ?  When you connect the VA11A to your Windows 7 64-bit PC, where in the Device Manager does the VA11A show up?  Does the device show up with an exclamation point (!)?  What kind of computer(s) were you using for your testing?

Sorry for all the questions, but I'm just trying to understand how to fix my problem.

Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #13 on: September 02, 2010, 10:58:04 AM »

I'm also having no issues using the VA12A on Win7 x64.
I can't remember the process but it seemed very simple.
Video will bloom though if you're running an AHP version below 3.236.

You're 100% sure you have it plugged into a USB 2.0 port?


« Last Edit: September 02, 2010, 11:30:24 AM by J.B. »
Logged

Don N

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 311
Re: Windows 7 PC and VA12A 64-bit drivers
« Reply #14 on: September 03, 2010, 11:48:06 AM »

J.B. -- This my is my port location    Port_#0008.Hub_#0002
Logged
Pages: [1] 2
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.