Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Pages: [1] 2 3 4

Author Topic: New iWatchmobile Release! Version 294  (Read 74786 times)

ErikP

  • Guest
New iWatchmobile Release! Version 294
« on: October 30, 2010, 04:21:10 AM »

The new installers have gone gold!  :o  or whatever its called for this distribution model.  The installers have been built and sent off to the server team to put online.  I don't have an ETA yet for when they will be done but the new versions will be available soon.

iWatchmobile PRO 294 Changes:
  New Dynamic Layout
    Video now scales to fit display on most devices
    Crops video to fit if smaller than camera feed resolution
    Stretches video to fit if larger than camera feed resolution
    UI element placement is now based on aspect ratio of display
  Streamlined Application Load
    Web application should load significantly faster on all devices
    Main application code significantly reduced in file size
    Many UI elements now load on demand instead of on initial start up
  Improved Reflector Performance
    Reflector server optimized for faster handling of web requests
  ActiveHome Pro Email Dialog fixes
    Mobile application invite cell phone dialog now correctly uses default information if set
    Fixed MyHouse email invite dialog layout
    Fixed crash after inviting a cell phone
    Fixed improper invite email formatting if direct email send fails
  Improved Blackberry Support
    Blackberry video rendering mode added to reduce black screen lag
    Reworked much of the web app layout to support Blackberry browser
  AHP now correctly releases its connection to x10net service on error
    Should not need to restart the x10net service anymore
  Other Bug Fixes
    Playback UI controls hide when settings tab is open
    Playback is no longer occasionally paused when the quick touch controls are selected

iWatchMobile 294 Changes:
  New Dynamic Layout
    Video now scales to fit display on most devices
    Crops video to fit if smaller than camera feed resolution
    Stretches video to fit if larger than camera feed resolution
    UI element placement is now based on aspect ratio of display
  Blackberry video rendering mode added to reduce black screen lag

As always please let us know how the new build is working for you, and I hope you all enjoy the new release  >!

Erik
Logged

PajamaGuy

  • Hero Member
  • *****
  • Helpful Post Rating: 32
  • Posts: 522
Re: New iWatchmobile Release! Version 294
« Reply #1 on: October 30, 2010, 07:55:19 AM »

Hey Erik - Thanks for the update!

I downloaded all 294 modules, but only installed AHP -  after which all modules->About screens showed 294.  Did installing only AHP actually update all modules, or should I install each one?

EDIT - ...and Erik, this one works!  For the first time I can access my system via Blackberry!  Way cool! 
« Last Edit: October 30, 2010, 08:06:08 AM by PajamaGuy »
Logged
PajamaGuy
Win-7 - Dell XPS -Automation
VA12a on a dedicated desktop - Video
XTB-IIR & V572RF32

Remote via LogMeIn (FREE) and Ignition

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #2 on: October 30, 2010, 09:43:07 AM »

Thanks kindly for the updates!  >!
Logged

Frank3d

  • Sr. Member
  • ****
  • Helpful Post Rating: 3
  • Posts: 120
Re: New iWatchmobile Release! Version 294
« Reply #3 on: October 30, 2010, 12:51:16 PM »

All, iWatchMobile V3.285 has been working fine for me on my iPhone 4 with port forwarding for 3G but I really wanted Presets and the other Pro functions would be icing on the cake. Well I got greedy and decided to upgrade to Pro V3.294 from iPhoneMobile standard V3.285. Im regretting it now. I invited a Cell in iWatchMobile Pro and went to either link (3G or wifi ) and for both I get the error " Cannot Open Page... Safari cannot open the page because it could not connect to the server "

But the biggest disappointment is that iWatchMobile standard that previously worked great on my iPhone does not work any more. When I bring it up on my iPhone4 I get the well known 500 error. I did restart the PC. Also it seems that when Internet Explorer is started it takes 30+ seconds for it to come up and did not previous to this upgrade. Once it does comr up it seems to work OK. Not sure if this is related to the upgrade.

I was wondering if I needed to download upgrades for AHP and all its plugins I have SW32A, SW33A, SW34A SW39A & SW45A? But as stated in a previous post all the plugins now show the latest release V3.294 even though I did not download them and only downloaded SW47A, SW49A & SW46A and installed them in that order. So I guess all was automatically upgraded.

Well again I state I was greedy and should have been satisfied with what I had and how well it was working.

ANY SUGGESTIONS FROM YOU ALL WOULD BE VERY MUCH APPRECIATED.

X10, thank you for this valuable forum......... Frank3d
Logged

PajamaGuy

  • Hero Member
  • *****
  • Helpful Post Rating: 32
  • Posts: 522
Re: New iWatchmobile Release! Version 294
« Reply #4 on: October 30, 2010, 01:08:46 PM »

FWIW - for the 1st time I was able to access iWatchmobile via my Blackberry this morning after loading 294.  Until then it was 400, 500, and unable to connect.  About an hour ago it all went to #$*& again.  The Blackberry gets 504 errors and the PC Web browser gets "Cannot connect"

Methinks 1w.x10 is having "issues"
Logged
PajamaGuy
Win-7 - Dell XPS -Automation
VA12a on a dedicated desktop - Video
XTB-IIR & V572RF32

Remote via LogMeIn (FREE) and Ignition

X10 Dev

  • Sr. Member
  • ****
  • Helpful Post Rating: 19
  • Posts: 125
Re: New iWatchmobile Release! Version 294
« Reply #5 on: October 30, 2010, 01:27:33 PM »

Also it seems that when Internet Explorer is started it takes 30+ seconds for it to come up and did not previous to this upgrade. Once it does comr up it seems to work OK. Not sure if this is related to the upgrade.
I just posted a response at http://forums.x10.com/index.php?topic=21449.msg122602#msg122602 that includes a setting to delay network startup.  by default, the 294 release starts listening to the network at boot.  There is a registry setting to go back to starting the network the first time AHP is launched.  Does running the delaynetworkstartup reg file, and then rebooting, help with Internet Explorer starting up?
Logged

X10 Dev

  • Sr. Member
  • ****
  • Helpful Post Rating: 19
  • Posts: 125
Re: New iWatchmobile Release! Version 294
« Reply #6 on: October 30, 2010, 01:45:59 PM »

FWIW - for the 1st time I was able to access iWatchmobile via my Blackberry this morning after loading 294.  Until then it was 400, 500, and unable to connect.  About an hour ago it all went to #$*& again.  The Blackberry gets 504 errors and the PC Web browser gets "Cannot connect"

Methinks 1w.x10 is having "issues"
Hmmm... I just checked -- iw.x10.com is working fine.  I have streams running to my PC, my iPhone, and my Droid.
1. Can your PC webbrowser connect in 'WiFi' mode?  Click on the WiFi link.  This is to make sure the iWatchMobile web server is running.
2. We don't generate a 504 error, ever.  So the 504 error is coming from somewhere else in the chain.  Maybe double-check the URL you are using on the Blackberry?
Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #7 on: October 30, 2010, 01:54:24 PM »

I'm actually getting a 500 error when trying to use the reflector service. The Wifi links are working fine.
This is on both the Blackberry and iTouch.

The server link is not working using any of 3 web browsers on my AHP PC either.

I have to say though, it's nice to connect through the browser and have a full window of video now.
Makes it much easier to monitor your cameras from any other computers you may use.  >!
« Last Edit: October 30, 2010, 02:01:57 PM by J.B. »
Logged

Frank3d

  • Sr. Member
  • ****
  • Helpful Post Rating: 3
  • Posts: 120
Re: New iWatchmobile Release! Version 294
« Reply #8 on: October 30, 2010, 03:42:08 PM »

Also it seems that when Internet Explorer is started it takes 30+ seconds for it to come up and did not previous to this upgrade. Once it does comr up it seems to work OK. Not sure if this is related to the upgrade.
I just posted a response at http://forums.x10.com/index.php?topic=21449.msg122602#msg122602 that includes a setting to delay network startup.  by default, the 294 release starts listening to the network at boot.  There is a registry setting to go back to starting the network the first time AHP is launched.  Does running the delaynetworkstartup reg file, and then rebooting, help with Internet Explorer starting up?

Yes it did, #:) Thank You. IE now starts normally. Can you now please help with the other part of my post of connectivity from my iPhone to iWatchMobile.
In MyHouse Status I get:0 PM Start Connection, 1 Connectivity to My House Svc, 2 Authenticated by My House Svc, 3 Waiting for remote users, 4 Cannot Connect to My House Svc, 5 Verify MyHouse Plug-in Registration, 6 Disconnected from MyHouse Svc, 7 Trying to Reconnect, all within 1.5 minutes.
Logged

Frank3d

  • Sr. Member
  • ****
  • Helpful Post Rating: 3
  • Posts: 120
Re: New iWatchmobile Release! Version 294
« Reply #9 on: October 30, 2010, 05:26:11 PM »

I'm actually getting a 500 error when trying to use the reflector service. The Wifi links are working fine.
This is on both the Blackberry and iTouch.

The server link is not working using any of 3 web browsers on my AHP PC either.

I have to say though, it's nice to connect through the browser and have a full window of video now.
Makes it much easier to monitor your cameras from any other computers you may use.  >!
J.B.

J.B.
I understand that because of internal X10 server problems why the reflector service may not work at times but my wifi link is not working either with the error message " Cannot Open Page" ... Safari cannot open the page because it could not connect to the server " is the message I get on my iphone4. Any ideas since your itouch is similar in operation to my iphone using wifi connectivity? TNX B:(
Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #10 on: October 30, 2010, 06:08:56 PM »

If the link is correct, there may be a chance that any firewall/anti-virus software running on your AHP computer may be blocking the connection.
You are able to bring up iWatchMobile from a web browser on the AHP system itself?
Logged

ErikP

  • Guest
Re: New iWatchmobile Release! Version 294
« Reply #11 on: October 30, 2010, 06:12:51 PM »

It looks like the 500 errors was a problem with the reflector server.  After stressing the server for a while some of the buffers got out of whack, so ActiveHome could connect for awhile if you restarted the x10net service but then it would die a few minutes later.  It should be fixed but now, are any of you still seeing this problem?  You may need to restart your x10net services to start working again, it looks like the bug was sending something down to the local x10net service which caused it to become unresponsive to any future communications from the reflector.

Quote
I was wondering if I needed to download upgrades for AHP and all its plugins I have SW32A, SW33A, SW34A SW39A & SW45A? But as stated in a previous post all the plugins now show the latest release V3.294 even though I did not download them and only downloaded SW47A, SW49A & SW46A and installed them in that order. So I guess all was automatically upgraded.
Right now the build number on the splash screen only reflects the version of the ActiveHome Pro core.  If there are more recent updates available for your plugins than the ones you installed you should update those as well to ensure everything is working with, and expecting the same versions.

We discussed this and will be changing the installers to just update everything.  The original reason for breaking everything up was to not choke up everyones internet with those "huge" 20MB that is the whole ActiveHome Suite.  With current internet bandwidth what it is, its probably best to go up to 20MB, and keep all the installed files clean and synced now.
Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #12 on: October 30, 2010, 06:17:32 PM »

I just closed AHP, killed the x10nets process, and restarted AHP.
Getting 500 errors trying to use the reflector.


Ok, this is kind of not cool to me.
I just got it to come up on the reflector with someone elses feed!!!


I should add, this was using the link generated in AHP for the reflector server.

« Last Edit: October 30, 2010, 06:28:45 PM by J.B. »
Logged

ErikP

  • Guest
Re: New iWatchmobile Release! Version 294
« Reply #13 on: October 30, 2010, 07:07:04 PM »

Try resetting your security key from the invite cellphone dialog, then restarting the computer?  Its possible to see this behavior from a corrupted security key, if the reflector can't find your connected system to get a feed from. 
Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #14 on: October 30, 2010, 07:10:10 PM »

Slight privacy issue isn't it?  :'
I normally don't use the reflector, I've had everything working fine with port forwarding.
I was just testing the connection as several people seem to be having some issues and randomly I was viewing someone elses video feed.
Logged
Pages: [1] 2 3 4
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.