Please login or register.

Login with username, password and session length
Advanced search  

News:

The New WIFI Module is now available!
                   *****Here's the link******

Pages: 1 [2] 3 4

Author Topic: New iWatchmobile Release! Version 294  (Read 72212 times)

ErikP

  • Guest
Re: New iWatchmobile Release! Version 294
« Reply #15 on: October 30, 2010, 07:24:51 PM »

Ah, I didn't realize that's what you meant  ???  I thought you meant you had gotten a friend's key.

It is a security issue, but it should only be an issue if you haven't updated your key recently  ;).  There was a bug which should have been fixed last release, where the key was not properly getting its seed values, so it was possible for 2 users to generate identical keys.

It also explains the 500 error.  outside the bug above it shouldn't happen publicly, but in testing with early internal versions I found that if two systems connect to the reflector with the same Xuid, any connecting client will get a 500 error when attempting to access either system through the reflector.  in that case if your system disconnected form the reflector for whatever reason, and theirs stayed connected and you attempted to view your cameras you would see their feeds.
Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #16 on: October 30, 2010, 07:28:54 PM »

I'm running the current build 3.294 and have verified all .dlls are this version.
I rarely have used anything other than Wifi, but this was most definitely not my video feed.
I just thought I should mention it, as I wouldn't want a random individual to access my camera feed.
There may still be some issues it appears?
« Last Edit: October 30, 2010, 07:30:35 PM by J.B. »
Logged

X10 Dev

  • Sr. Member
  • ****
  • Helpful Post Rating: 19
  • Posts: 125
Re: New iWatchmobile Release! Version 294
« Reply #17 on: October 30, 2010, 08:18:31 PM »

I'm running the current build 3.294 and have verified all .dlls are this version.
I rarely have used anything other than Wifi, but this was most definitely not my video feed.
I just thought I should mention it, as I wouldn't want a random individual to access my camera feed.
There may still be some issues it appears?
Yes, thanks for mentioning it.  Unlike some social networking companies, we take privacy seriously.  The security key you put in the URL to connect is the same key your copy of AHP uses to connect.  The reflector matches the two up and passes information back and forth.  The security key is based on your registration code plus a 64 bit cryptographically random number.  So the connection is private to just you.  Noone at X10 can monitor the video either, FYI.  And you can change your key at any time.

We *should* be at a completely stable AHP and reflector with the 294 release.   :'  It seems that there might be some reflector issues.  I'm working on it, and will report back here when I have a fix...



Logged

BaBaLou.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 244
Re: New iWatchmobile Release! Version 294
« Reply #18 on: October 31, 2010, 05:51:51 AM »

Just checking that the issues with OnAlert is still on the table.  B:(
                                I saw no changes yet and noted non in the intro of this topic.  :)+

        Which brings me to the point of having to say thanks and a "Helpful" to ErikP for the topic of a new Update. :)%
   Hope to see it a habit in letting us know of any future releases and updates. Getting tired of doing the daily Check for the next update and guessing on what it will fix or add.

I must say it has been good practice though in having to update everything in what seems a weekly ritual.
« Last Edit: October 31, 2010, 05:53:38 AM by BaBaLou. »
Logged

PajamaGuy

  • Hero Member
  • *****
  • Helpful Post Rating: 32
  • Posts: 522
BB Bold Screen controls missing
« Reply #19 on: October 31, 2010, 07:20:14 AM »

Yesterday morning, I loaded 294 and everything worked - then there were reflector problems and it didn't work for the rest of the day (504, 400, 500 errors)

This morning it works again - however the main options/control button is missing from the Blackberry screen.  The bottom-right button that opens up the options is NOT there on the BB, but it is there on the web browser??

Logged
PajamaGuy
Win-7 - Dell XPS -Automation
VA12a on a dedicated desktop - Video
XTB-IIR & V572RF32

Remote via LogMeIn (FREE) and Ignition

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #20 on: October 31, 2010, 10:57:22 AM »

Quote
The bottom-right button that opens up the options is NOT there on the BB, but it is there on the web browser??

This also happens to me at times.
When I first installed this latest build the slide-out menu button did not appear but I could still click the area and have the menu open.
This only happens on my Blackberry.
Logged

X10 Dev

  • Sr. Member
  • ****
  • Helpful Post Rating: 19
  • Posts: 125
Re: BB Bold Screen controls missing
« Reply #21 on: October 31, 2010, 01:01:45 PM »

This morning it works again - however the main options/control button is missing from the Blackberry screen.  The bottom-right button that opens up the options is NOT there on the BB, but it is there on the web browser??

If you refresh the page, does the menu tab reappear?  Which Blackberry version do you have again?
Logged

Icu2

  • Jr. Member
  • **
  • Helpful Post Rating: 1
  • Posts: 24
Re: New iWatchmobile Release! Version 294
« Reply #22 on: October 31, 2010, 04:26:43 PM »

Hi PajamaGuy and J.B.,  I have a BlackBerry Bold 9700 and this is what I found.

If was viewing the page in "Column View", I would get a black screen with no controls but when I switched to "Page View" I could see the control icons.
I was wondering if this might work for either of you guys.

Logged
"I have learned that no man has the right to look down at another man, unless it's to help him get back on his feet."

BlackBerry Bold 9700

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #23 on: October 31, 2010, 04:48:32 PM »

Other than a few intermittent issues, iWatchMobile Pro is actually working fairly well for me.
I normally only use the Blackberry when I'm not able to use my local Wifi.
I find using my iTouch to be much quicker and a better experience overall.

I am more or less just trying to pass along any info or issues and testing usage on the Blackberry.
My Blackberry isn't actually a Bold, but an 8530.
It appears some of the issues aren't model specific.
My Blackberry is set to page view when I see these things occur.
Thanks for the info though, it may prove helpful to others.  >!
Logged

Frank3d

  • Sr. Member
  • ****
  • Helpful Post Rating: 3
  • Posts: 120
Re: New iWatchmobile Release! Version 294
« Reply #24 on: October 31, 2010, 05:38:13 PM »

If the link is correct, there may be a chance that any firewall/anti-virus software running on your AHP computer may be blocking the connection.
You are able to bring up iWatchMobile from a web browser on the AHP system itself?

J.B.             Sun. 5:35 Eastern,
Yes I can  #:) >!and works pretty nice I may add. >! Now if I can only get it to work that nice on my iPhone4.
In AHP do I still need to manually connect to MyHouse Service for 3G to my iPhone?
Buy the way I use Trend Micro for my AV and never had any problems using the iWatchMobile V 3.285 through my iPhone using port forwarding on 3G.
Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #25 on: October 31, 2010, 05:55:33 PM »

MyHouse shouldn't really have anything to do with iWatchMobile as far as I know.
Are you able to get it to work by manually typing out the URL on your iPhone?
http://youripaddress:8777/iwatchpro
Logged

Frank3d

  • Sr. Member
  • ****
  • Helpful Post Rating: 3
  • Posts: 120
Re: New iWatchmobile Release! Version 294
« Reply #26 on: October 31, 2010, 06:31:58 PM »

MyHouse shouldn't really have anything to do with iWatchMobile as far as I know.
Are you able to get it to work by manually typing out the URL on your iPhone?
http://youripaddress:8777/iwatchpro

J.B. Sun 6:29pm EDT
From the iPhone No and still the responce is "500 error". Same with a PC elseware in the house wired (not wireless ) to my network router.
Using    http://my external ip:8777/iwatchpro     that use to work fine with iWatchMobile V3.285.
Logged

X10 Dev

  • Sr. Member
  • ****
  • Helpful Post Rating: 19
  • Posts: 125
Re: New iWatchmobile Release! Version 294
« Reply #27 on: October 31, 2010, 06:49:27 PM »

From the iPhone No and still the responce is "500 error". Same with a PC elseware in the house wired (not wireless ) to my network router.
Using    http://my external ip:8777/iwatchpro     that use to work fine with iWatchMobile V3.285.
Is there any text after the '500 error'?  I went through and made some of the errors more descriptive.
Logged

J.B.

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 319
Re: New iWatchmobile Release! Version 294
« Reply #28 on: October 31, 2010, 06:59:49 PM »

Quote
Using    http://my external ip:8777/iwatchpro     that use to work fine with iWatchMobile V3.285.

Will your internal IP for the system running AHP work?

Does your router act as a DHCP server?
This would change your internal IP each time the system is restarted and could cause any port forwarding to stop working if setup with a previous IP.

If using your external IP and your ISP issues you a dynamic IP, this will also cause the setup to stop working unless you are using the current IP or using a DynDNS service which resolves your current IP to a domain name.

« Last Edit: October 31, 2010, 07:01:57 PM by J.B. »
Logged

Frank3d

  • Sr. Member
  • ****
  • Helpful Post Rating: 3
  • Posts: 120
Re: New iWatchmobile Release! Version 294
« Reply #29 on: October 31, 2010, 08:01:00 PM »

From the iPhone No and still the responce is "500 error". Same with a PC elseware in the house wired (not wireless ) to my network router.
Using    http://my external ip:8777/iwatchpro     that use to work fine with iWatchMobile V3.285.
Is there any text after the '500 error'?  I went through and made some of the errors more descriptive.


There is NO TEXT AFTER THE 500 ERROR for either a PC on my home network or my iPhone4. This is with iPhone using my external ip in the link adr or using the AHP PC's ip in the Link adr from another PC on my home network.
Also when I tried using the link emailed to me for a cell invite to iWatch mobile, the web brouser that iPhone4 uses ( Safari ) shows "Cannot connect to the server". So I tried http://external ip:8777/iwatchpro in the iphones browser (safari) then I get the 500 error without any other text. Remember all worked well using the same adr except without "pro" on the end and iwatch V3.285 worked excellent before the pro upgrade.

I hope Im getting close to resolving this problem. 
Logged
Pages: 1 [2] 3 4
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.