Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: Challenging issues with DS10A and macros  (Read 12971 times)

orcusomega

  • Sr. Member
  • ****
  • Helpful Post Rating: 6
  • Posts: 97
Challenging issues with DS10A and macros
« on: November 22, 2010, 08:35:40 PM »

Just need a sanity check here.  I am looking for a macro that will flash lights if a contact is open.  Basically, I have two garage doors, mine and Amy's.I am looking for a macro to react to a command from an SS13 that will check the status of the garage door and if the contact is open, flash the correct lamp - mine if mine is open, hers if hers is open.

I started working on this but I cannot get the condition set for the sensor.  In AHP, it shows the door is closed.  When I trip the door, AHP recognizes the door opening, and state changes in AHP, so I dont think it is a communication issue.  I confirmed this is also the case with the other DS10A in the same room.

Example: Door is actually closed, AHP shows contact as closed.

Condition: Not open = AHP says its is true and runs macro
COndition: Exactly Open = AHP says its is true and runs macro
Condition: Not Closed = AHP says its is true and runs macro
Condition: Exactly Closed = AHP says its is true and runs macro

So then I trip the door, AHP shows the contact open, and I run the same use cases, and the same results.

So what am I doing wrong?  Any help is appreciated!

Bob
Logged

orcusomega

  • Sr. Member
  • ****
  • Helpful Post Rating: 6
  • Posts: 97
Re: Challenging issues with DS10A and macros
« Reply #1 on: December 03, 2010, 02:32:12 PM »

Help guys, this is becoming a SERIOUS problem!  I cannot do anything based on the status of these devices - I know that AHP can see the sensors, since I can see them open and close when I trip the door!

Bob
Logged

troll334

  • Hero Member
  • *****
  • Helpful Post Rating: 11
  • Posts: 159
Re: Challenging issues with DS10A and macros
« Reply #2 on: December 03, 2010, 03:22:47 PM »

Hi Bob,
I have no experience with the security sensors. What does the AHP log indicate?
Does it show the trip happening? If so, is the next log record a Macro entry?
If you click on the Macro in AHP, does the corresponding light do what you expect?
Logged
AHP 3.236. CM15A. XTB-IIR. XTBM. Hauppauge 950Q.

orcusomega

  • Sr. Member
  • ****
  • Helpful Post Rating: 6
  • Posts: 97
Re: Challenging issues with DS10A and macros
« Reply #3 on: December 03, 2010, 03:54:49 PM »

Troll,

Thanks for the response!  I can trigger a macro when the state changes i.e. when the garage door opens, I can have a light flash etc.  But I cannot say "If the sensor is open, close the door" - AHP says the same thing every time.  I have even re-bound the sensors to AHP - nada....

Thanks!

Bob
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 289
  • Posts: 12699
Re: Challenging issues with DS10A and macros
« Reply #4 on: December 03, 2010, 04:00:08 PM »

Remember the MS10A and DS10A also send an I am alive signal, I believe every two hours, so a security console knows if they are OK.
Logged

troll334

  • Hero Member
  • *****
  • Helpful Post Rating: 11
  • Posts: 159
Re: Challenging issues with DS10A and macros
« Reply #5 on: December 03, 2010, 04:05:28 PM »

So how often do you want to check on the status?
have you played around with delays (in macros) and timers (for macros)?
If you're planning to manually check on the status from time-to-time, it should be easy
in AHP to set a flag when "Door Open" is true. Then, from time-to-time, check in and run a macro that
checks on the status of the flag. If flag(s) set then issue the door down action.
I'm I close or way off base?
Logged
AHP 3.236. CM15A. XTB-IIR. XTBM. Hauppauge 950Q.

orcusomega

  • Sr. Member
  • ****
  • Helpful Post Rating: 6
  • Posts: 97
Re: Challenging issues with DS10A and macros
« Reply #6 on: December 03, 2010, 04:29:51 PM »

Thanks Troll - I think that this and the thread over here (http://forums.x10.com/index.php?topic=21999.0) are related... not sure how though, but I definately appreciate the help sofar!

Bob
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.