Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: Editing Quirks  (Read 7465 times)

LemonAid

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 3
Editing Quirks
« on: December 05, 2010, 12:57:44 AM »

1.) Today I found out the hard way, that apparently editing any of the HERS Favorite channels is a bad idea, at least with my IR43a with firmware MUS0AUSS1DU4-06/10/10-1.

- After being done with the change and the display of "Saving Settings", all of my HIS Favorite channels had been replaced by a copy of HERS.
- After tediously punching in all of HIS channels settings again using the Wizard and watching "Saving Settings" at exiting, I had to find that all of HIS favorites either stayed the same instead or already had been immediately replaced once more by HERS. Not nice at all!

Others seeing this kind of issue as well?

I really wished that there would be an easy and platform independent way (like RS-232 and a terminal program) to save and restore all of those learned codes and labels using a computer and to apply firmware fixes.


2.) How does one edit a label, relocate or delete a learned IR code which is assigned to a Side Key?


BTW, the ALL ROOMS button is here associated with the Play punchthrough group, which isn't documented in the Owner's Manual and took me quite some time to eventually figure out.
Logged

Wannabe

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 2
Re: Editing Quirks
« Reply #1 on: December 28, 2010, 12:00:42 PM »

I've found that reading the manual and skipping the wizard eliminated those problems you've described.

Also, on page 6 below the image explains the 'colored' button descriptions.
Logged

LemonAid

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 3
Re: Editing Quirks
« Reply #2 on: December 29, 2010, 07:42:12 AM »

I've found that reading the manual and skipping the wizard eliminated those problems you've described.

Where in the manual did you find how to edit or delete an assigned and labeled side key?

In the meantime, I received my replacement remote, which so far doesn't show the overwriting of HIS with the contents of HERS when editing a favorite of HERS.

But when trying to get all my previous programming back into the new device, I ran into a new, previously unseen issue with X10 time delays.

When I do the following programming:
HOME -> SETUP -> X10 Macros: M2 -> Pick Module:Bedroom -> A1:Off -> Set Delay:9s -> Save:"Macro M2: A1 Off" [-> Done]     <== Where is 9s Delay????? A1(TM751) switches off immediately!!
 
after saving, the 9s time delay information is NOT displayed anymore and when executing:
  HOME -> X10 Macros -> M2
the TM751 switches off immediately, without performing the requested 9s delay.
 
I tried it with different side keys and different delays, the result is always the same: after the SAVE step, the time delay is gone.
 
Am I missing something here or is this now yet another bug in just another area?
Logged

danmanx10

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 3
Re: Editing Quirks
« Reply #3 on: December 30, 2010, 11:56:01 PM »

Just my opinion but it looks to me like your macro is:
A1 off
delay-9

It executes in this order. A1 off executes immediately. The delay would occur after that - since you don;t have a subsequent command, the delay, in effect, does nothing and may "disappear." If you want the delay before A1 off, try something like this:

N16 off
delay-9
A1 off

Where N16 is a nonexistent device. You'd need to define N16 in one of the Nstinct's X10 "rooms" in order to add it to the macro. But the device does not need to exist in reality.

Just my guess but that's what I would try.
 >!
Logged

LemonAid

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 3
Re: Editing Quirks
« Reply #4 on: February 12, 2011, 08:22:36 PM »

Well, I don't think so, since the delay option is part of the currently worked on device command.

In my first IR43a, which overwrote HIS favorites with the contents of HERS whenever those were edited, the delay worked that way as expected. After selecting the desired delay and 'Save'ing it, the time amount was displayed for that macro right under the device's address and switch-to state.

With both replacements that I received since, that very thing now does not happen anymore.  The delay now is simply missing after 'Save' and apparently doesn't make it anymore into the actual execution code.

XT040 is the batch number of this latest remote; the reported firmware version is still the same.
« Last Edit: February 12, 2011, 08:49:28 PM by LemonAid »
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.