Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: SoftStart problems with AHP and the SDK  (Read 3095 times)

Noam

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 49
  • Posts: 2800
SoftStart problems with AHP and the SDK
« on: January 19, 2011, 11:27:58 AM »

I have been using the older (non-SoftStart) lamp modules for many years, but I decided to order a few of the newer SoftStart ones, to see what all the fuss was about.
I really like the ramping up and down, and the use of Extended codes to move to an exact dim level, regardless of the starting point.

However, I found a few issues:

1) Using the AHCMD.exe utility, I was comparing the differences between the behavior of the two versions of the Lamp Module. I ran the following tests:

     a) Using an OLD Lamp Module, and the traditional "BRIGHT" and DIM" commands:
          AHCMD SendPLC C13 BRIGHT 100
          AHCMD SendPLC C13 DIM 80
     This works just fine (as it always did). The lamp comes up to 100%, then dims down to about 20%.

     b) Using a NEW Lamp Module, and Extended Codes:
          AHCMD SendPLC C14 ExtCode 31 0D (there is no 20% - only 19% or 21%).
     This worked, and the lamp came up from 0 to about 20%.

     c) Using a NEW Lamp Module, and the traditional "BRIGHT" and DIM" commands:
          AHCMD SendPLC C14 BRIGHT 100
          AHCMD SendPLC C14 DIM 80
     The lamp came up to 100%, but then it dimmed down to a MUCH lower (nearly off) level.

I don't know if this is a bug in the way the NEW LM465 interprets the older "bright" and "dim" commands, or in the way AHCMD.exe is sending them to the powerline.

2) AHCMD.exe crashed several times during my testing, specifically when I was sending "dim" commands. Might be a bug in there, too.

3) As a test, I created a macro in AHP that turned on an OLD Lamp Module to 50%. I saved and downloaded to my CM15A, and that worked fine.
However, when I changed the module type in AHP to a NEW Lamp Module, AHP noticed that I needed to re-save the macro (the little "floppy disk" icon showed up - how many young people even know what that icon means?), but never prompted me to re-download it (no "download" icon at the bottom). Running the macro still sent the old "bright" and "dim" commands.
However, after I downloaded the program again, it worked fine.
AHP should be prompting for a re-download, if a module type is changed, since that affects the program stored in the CM15A.

I am running AHP 3.304, with the SmartMacros plugin, and the latest SDK.
I did report all of this directly to the AHP developers I've been working with.

Has anyone else had similar experiences?
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.