Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Author Topic: WIFI Error  (Read 5299 times)

helihead

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 4
WIFI Error
« on: September 11, 2011, 11:51:18 AM »


I have my Airpad connecting to my wireless network using wpa/wpa2 psk.  It detects the network and connects fine.  When I shut the Airpad off and bring it back up, the network is never connected.  When I go look at the Wireless settings it says "Error" under "WiFi" and the box to use it is unchecked.  All I have to do is recheck it and it connects just fine.

This is not a deal breaker but having to open the wireless settings and recheck everytime I want to use the Airpad is a real pain.

Any suggestions?

Thanks
Logged

X10 Dev

  • Sr. Member
  • ****
  • Helpful Post Rating: 19
  • Posts: 125
Re: WIFI Error
« Reply #1 on: September 11, 2011, 03:58:02 PM »

Any suggestions?

We'll take a look at this.  You would think if the Airpd knows there was an error condition and that trying again will fix the problem then this process could just be automated.
Logged

helihead

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 4
Re: WIFI Error
« Reply #2 on: September 11, 2011, 04:18:08 PM »

Not only that but it's obvious that it can connect because all I have to do is check the WI-Fi checkbox again and it goes right on the network and get's an IP.

Logged

Tesla

  • Sr. Member
  • ****
  • Helpful Post Rating: 4
  • Posts: 79
Re: WIFI Error
« Reply #3 on: September 11, 2011, 04:59:19 PM »


I have my Airpad connecting to my wireless network using wpa/wpa2 psk.  It detects the network and connects fine.  When I shut the Airpad off and bring it back up, the network is never connected.  When I go look at the Wireless settings it says "Error" under "WiFi" and the box to use it is unchecked.  All I have to do is recheck it and it connects just fine.


I have also seen this behavior.

The connection can survive sleep-mode, but usually not a reboot or power off-on. However, about 1 out of 5 times it does (a shut-down and reboot cycle anyway).

I thought it might be because the AirPad has generally poorer WiFi reception than my laptop ... but I just did some testing with the AirPad very close to the router. While the Wifi indicator had all bars lit, it didn't seem to make a difference on the above tests.

« Last Edit: September 11, 2011, 05:21:17 PM by Tesla »
Logged

YB

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 173
  • Coders Are The Only True Evils In This World...
    • X10 WTI
Re: WIFI Error
« Reply #4 on: September 12, 2011, 08:05:14 PM »

I am having the same issue, it should be fixed in the official update (we do not have an ETA on this yet).
Logged
Michael Youngblood
Web Designer

DemDave

  • Full Member
  • ***
  • Helpful Post Rating: 1
  • Posts: 50
Re: WIFI Error
« Reply #5 on: September 26, 2011, 11:04:32 PM »

I'm not sure if this is the same issue or something unrelated:

On my Android phone, you can turn the screen off and apps will continue to run in the background (and can still use the data connection).

Putting the Airpad to sleep, however, seems to shut off the wifi connection. Apps that I'd like to continue running (like Samba file sharing, eBuddy, and a few others) stop functioning.

When I take the Airpad out of sleep mode, the wifi automatically reconnects and I get messages telling me the apps lost the connection and are reconnecting.

I'd like to be able to keep them running, but with the screen turned off to save the battery.


Logged

YB

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 173
  • Coders Are The Only True Evils In This World...
    • X10 WTI
Re: WIFI Error
« Reply #6 on: September 27, 2011, 02:09:18 PM »

Greetings DemDave,

You can change the settings of your WiFi while the device is sleeping. Go to your settings menu > Wireless Networks > Wifi > Click the menu key > advanced settings > and alas, there is a option for while your device sleeps, what to do with wifi. to have your apps keep running via wifi, select never turn off wifi.
Logged
Michael Youngblood
Web Designer

pohs

  • Jr. Member
  • **
  • Helpful Post Rating: 0
  • Posts: 23
Re: WIFI Error
« Reply #7 on: October 09, 2011, 09:22:24 AM »

Have the same problem with wifi when starting my Airpad. However, I have found if it is plugged into the charger it will load my wifi.
Logged

everydayflyer

  • Hero Member
  • *****
  • Helpful Post Rating: 5
  • Posts: 190
Re: WIFI Error
« Reply #8 on: October 09, 2011, 12:31:26 PM »

Have the same problem with wifi when starting my Airpad. However, I have found if it is plugged into the charger it will load my wifi.

Sounds like your  Wi-F- sleep policy  is set  to

Never when pluged in.

other choices are

When screen turns off

Never

 Setting are here
Networks / Wi Fi Settings  / Menu / Advanced /Wi Fi sleep policy.


just noticed I duplicated post #6 above, oh well.
« Last Edit: October 09, 2011, 12:50:58 PM by everydayflyer »
Logged

pohs

  • Jr. Member
  • **
  • Helpful Post Rating: 0
  • Posts: 23
Re: WIFI Error
« Reply #9 on: October 09, 2011, 07:15:08 PM »

Thanks everydayflyer; everything working correctly now.
Logged

Walt725

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 1
Re: WIFI Error
« Reply #10 on: January 31, 2012, 04:11:45 PM »

I just purchased the AirPad7 with Android 4.0.1 installed.  Regardless of the settings of WiFi policies stated above, the connection ALWAYS drops when the unit enters sleep mode. 
Ironically, one of my installed apps was able to detect this and correct the problem, even though it made no visible change to the WiFi policies.  However when you kill the app, the problem returns.  Sleep mode = no Wifi.

What suggestions does anyone have.
Thanks


Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.