Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: sending to multiple email addresses  (Read 6914 times)

Andytec

  • Jr. Member
  • **
  • Helpful Post Rating: 0
  • Posts: 17
sending to multiple email addresses
« on: November 27, 2011, 01:16:16 PM »

How can I send the same data to multiple email addresses on an alarm event without having to create the same macros for each email address ?

Thanks
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9456
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: sending to multiple email addresses
« Reply #1 on: November 27, 2011, 01:55:38 PM »

AHP doesn't allow multi address selection.
However you can still send to multiple users using one macro.
there are a couple of ways to do this:
1:Drag  the email notification into the macro command for each recipient.

2:In the email address type the first recipient followed by a ; then the next address

Note: this works for sending pictures to multiple addresses too!
 >!
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Andytec

  • Jr. Member
  • **
  • Helpful Post Rating: 0
  • Posts: 17
Re: sending to multiple email addresses
« Reply #2 on: November 27, 2011, 03:10:18 PM »

Thanks very much - that works ! - great. Any idea why I get two emails to each address for each email action in the macro.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9456
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: sending to multiple email addresses
« Reply #3 on: November 27, 2011, 03:47:51 PM »

It may have something to do with your email settings in AHP I have mine set to send using SMTP.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Noam

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 49
  • Posts: 2800
Re: sending to multiple email addresses
« Reply #4 on: November 27, 2011, 05:01:18 PM »

Thanks very much - that works ! - great. Any idea why I get two emails to each address for each email action in the macro.

Is AHP open when you are doing this? I'm pretty sure that as long as the PC is on, and the X10nets service is running, AHP no longer needs to be open.
HOWEVER, there is a bug that got introduced a few version ago. This bug seems to run all macro (and timer) actions twice, BEFORE AHP is opened for the first time after the Pc is booted/rebooted, or the x10nets service is started/restarted.

I don't know if that's the explanation for your symptoms, but if you are booting (or rebooting) the Pc, and NOT opening AHP, then you might see this behavior. The fix is as simple as opening AHP after you boot or reboot the PC. You can then close it right away, if you want. The act of opening it stops the duplicate actions. I'm not sure why it is happening, but it was reported to the developers already (and it is on the Bug List - located here: http://forums.x10.com/index.php?topic=22373.0)
Logged

Andytec

  • Jr. Member
  • **
  • Helpful Post Rating: 0
  • Posts: 17
Re: sending to multiple email addresses
« Reply #5 on: November 27, 2011, 06:16:43 PM »


SMPT _ yes thats what I have set up

I only have AHP running on the laptop. I always open AHP and leave it open after start-up

a

Logged

Noam

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 49
  • Posts: 2800
Re: sending to multiple email addresses
« Reply #6 on: November 27, 2011, 08:21:59 PM »

Are other commands in the macro running twice?
There is a bug in the list (that I'd forgotten about) where macros triggered by security events run twice.
« Last Edit: November 27, 2011, 08:24:29 PM by Noam »
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.