Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: MyGarage Mobile App for 2 doors  (Read 9699 times)

ryonholland

  • Jr. Member
  • **
  • Helpful Post Rating: 1
  • Posts: 10
MyGarage Mobile App for 2 doors
« on: November 23, 2010, 02:24:31 AM »

I got it working to control 2 doors with the MyGarage Mobile App.  This way, I can close them accordingly.  The only part I can't figure out is how to link a DS10A to both doors to show the red/green light in the MyGarage Mobile App.  I don't care which door it is telling me that is open, I just want to know that one/both are open or that both are closed.  Let me know if you have any ideas on this.

These are my modules and sensors:
UM506 Universal Module for Door 1 = A14 (Labeled Door 1 Module)
UM506 Universal Module for Door 2 = A15 (Labeled Door 2 Module)
FAKE/GHOST UM506 = B1 (Labeled MyGarage Module)
DS10A Door Sensor on Door 1 = (Labeled Door 1)
DS10A Door Sensor on Door 2 = (Labeled Door 2)

MyGarage Mobile app is setup to control the B1 (ghost) Module.

Here is how I did the Macro (you need to put SmartMacros in advanced mode for this - See Preferences)  I added the delays so that each macro would run a few seconds after the last one.  Not sure if it helped or not but it seemed more consistent after I did that.

B1 ON and with the following conditions:  (This closes only door 1 because door 2 is already closed)
        If Door 1 is open AND Door 2 is closed
        Delay 1 second
        Turn on A14
        Delay 3 Seconds
        Turn off A14
ELSE
B1 ON and with the following conditions: (This closes only Door 2 because door 1 is already closed)
        If Door 1 is closed AND Door 2 is open
        Delay 3 seconds
        Turn on A15
        Delay 3 Seconds
        Turn off A15
ELSE
B1 ON and with the following conditions: (this closes both doors that are open)
        If Door 1 is open AND Door 2 is open
        Delay 5 seconds
        Turn on A15
        Delay 3 Seconds
        Turn off A15
        Delay 3 Seconds
        Turn on A14
        Delay 3 Seconds
        Turn off A14
ELSE
B1 ON and with the following conditions:  (This opens only door 1 when both are closed) I did it like this so I could open only door 1 when both are closed.  There really isn't a way to say which to open with the MyGarage Mobile app so i figured door 1 would be better since that is where I park the cars.
        If Door 1 is closed AND Door 2 is closed
        Delay 7 seconds
        Turn on A14
        Delay 3 Seconds
        Turn off A14

Let me know if you have a solution to the sensor issue...
Logged

ryonholland

  • Jr. Member
  • **
  • Helpful Post Rating: 1
  • Posts: 10
Re: MyGarage Mobile App for 2 doors
« Reply #1 on: November 23, 2010, 10:56:12 PM »

I got it figured out.  I added a 3rd DS10A and put 2 switches on it.  I named this one "MyGarage Sensor."  One switch on each door.  http://kbase.x10.com/wiki/Adding_A_Switch_To_A_Door_Sensor.  I put them on opposite sides of each door to avoid the MyGarage switch from passing by the Garage1/Garage 2 switch and creating a closed signal as doors open.

I then setup MyGarage plugin to detect the MyGarage Sensor.  Now I get a red light on my MyGarage Mobile App if either door is open.  Then with the macro I used earlier, I can close whichever door is open.

Pretty sweeeeet!!  Now next week they will probably come out with an update to the plugin that controls 2 doors.  B:(
Logged

JMac

  • Hero Member
  • *****
  • Helpful Post Rating: 23
  • Posts: 462
Re: MyGarage Mobile App for 2 doors
« Reply #2 on: November 24, 2010, 08:08:21 AM »

Nice solution - thanks for sharing.
Logged

ryonholland

  • Jr. Member
  • **
  • Helpful Post Rating: 1
  • Posts: 10
Re: MyGarage Mobile App for 2 doors
« Reply #3 on: November 29, 2010, 05:55:44 PM »

Well. That doesn't work as well as I thought.  Only about 10% of the time.  The problem with having 2 DS10A's on the same door is that when it opens, both signals are sent at the exact same time and activehome doesn't read them correctly.  When I remove the MyGarage sensor (see my post), and each door just has one sensor, AHP reads the trigger and closing perfectly.  But when you mix 2 of them at the same time, it gets screwed up.

So I am back to just being able to close both, but I can't see if they are open or not using the MyGarage Mobile App.  They need to change the software to allow the mobile app to read ANY type of sensor/module.  Then I could use a magnetic switch and a PowerFlash interface for the MyGarage Sensor and all would be good.  Or they just need to have the software monitor 2 doors seperately.  Any thoughts or feedback as to something I might be missing would be awesome.

Thanks.
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.