Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Author Topic: PS561 speaker "horn" issue.  (Read 2145 times)

doctester

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 1
PS561 speaker "horn" issue.
« on: March 30, 2012, 06:23:15 PM »

My unit was dropped.   Wonderful.   It still works but the "speakers" or sirens barely make a sound.  Is there any type of replacement for these or an extension I can install to hear the "chimes" again?  Is the side jack a port for external speakers?

Any help would be appreciated.


Sucks that I can't hear a customer come in anymore :(
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 289
  • Posts: 12766
Re: PS561 speaker "horn" issue.
« Reply #1 on: March 30, 2012, 06:43:16 PM »

The jack on the side is an earphone jack. So you could listen to your outgoing security message.
The sounder or sounders {I don't know it it has one or more in parallel} is a Piezo type.
Most likely glued to the case. Maybe they just came loose and are floating inside the case.
Though Piezo Sounders are fragile. They may have cracked as X10 doesn't have them in a shell just glued to the case.
You can buy Piezo sounders but we would have to find a suitable replacement as X10s are a high voltage very small current type.
« Last Edit: March 30, 2012, 06:49:48 PM by Brian H »
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.