Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: Dropped My PSH01 Powerhorn  (Read 2337 times)

tom j

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 1270
Dropped My PSH01 Powerhorn
« on: August 24, 2012, 04:54:14 PM »

Hi guys well I dropped one of my Powerhorns  B:( the most expensive one the PSH01 and it stopped working took the screws out and all seems well from what I can see thought maybe something came loose but I don't see anything. Just wondering if you think it can be repaired they are running 30 bucks for the Pro on eBay so I just order a PH508 found that one for only 22 bucks with free shipping.  :)% but I still like my H01 so thought I would ask what you guys think and maybe how I could trouble shoot it. Really didn't fall that far kind of surprised it stopped working have dropped a lot of other x10 stuff but this is the first to break after a shot fall.  :P :-[ :-\


Tom
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 288
  • Posts: 12664
Re: Dropped My PSH01 Powerhorn
« Reply #1 on: August 24, 2012, 06:18:33 PM »

I have seen two hardware versions of the PH508/PSH01.
Do you have an approximate age?
I would look at the fine wires running from the board to the sounder elements. They are fragile and one may have been broken off by the fall.
Logged

tom j

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 1270
Re: Dropped My PSH01 Powerhorn
« Reply #2 on: August 24, 2012, 06:22:33 PM »

I have seen two hardware versions of the PH508/PSH01.
Do you have an approximate age?
I would look at the fine wires running from the board to the sounder elements. They are fragile and one may have been broken off by the fall.


Thanks yeah first thing I looked at was those wires will look again but they seem to be in fine shape. Just doesn't seem to be anything on that board that is that fragile. Humm any other ideas.   ???


Tom
« Last Edit: August 24, 2012, 06:43:09 PM by tom j »
Logged

tom j

  • Hero Member
  • *****
  • Helpful Post Rating: 16
  • Posts: 1270
Re: Dropped My PSH01 Powerhorn
« Reply #3 on: August 24, 2012, 06:24:14 PM »

Ill have to look and check if I can see the age I've had it maybe four years doesn't get much use except when I test the system every month or so.


Tom
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 288
  • Posts: 12664
Re: Dropped My PSH01 Powerhorn
« Reply #4 on: August 24, 2012, 07:51:28 PM »

Check the piezo sounders. They are fragile and may have cracked.
Logged

dave w

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 136
  • Posts: 5955
Re: Dropped My PSH01 Powerhorn
« Reply #5 on: August 25, 2012, 10:55:58 AM »

If you can solder and have a good iron, you might try and re-flow the solder connections.
Logged
"This aftershave makes me look fat"
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.