Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Author Topic: Signal boost advice needed...  (Read 358 times)

VinRin57

  • Full Member
  • ***
  • Helpful Post Rating: 0
  • Posts: 51
Signal boost advice needed...
« on: December 28, 2018, 04:49:19 PM »

I have a couple of Powerhouse mini controllers sitting idle and are needed. Problem: no matter which outlet I plug it in, it's just not powerful to trigger the outside lights. It is true I have 2 breaker panels in the basement, the WM100 plugged in right next to it, and a Leviton 2 phase coupler/blaster wired into the panel. BUT I am simply unable to get the signal from kitchen outlet to the basement. Lunching the app every time is ridiculous! Is there something I can do with the mini? Plug it in to something? Thoughts? Thanks! B:(
Logged

brobin

  • Hero Member
  • *****
  • Helpful Post Rating: 136
  • Posts: 722
Re: Signal boost advice needed...
« Reply #1 on: December 28, 2018, 04:57:28 PM »

You need the XTB-IIR. It is simply THE best solution to solving X10 signal issues. Get one while you can as they are being discontinued. It is worth every penny!  http://jvde.us/xtb-iir.htm
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 291
  • Posts: 12828
Re: Signal boost advice needed...
« Reply #2 on: December 28, 2018, 06:12:06 PM »

You may want to look at Jeff's Troubleshooting Tutorials for some tips on X10 issues.
http://jvde.us/x10_troubleshooting.htm
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.