Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Pages: 1 [2] 3 4 5

Author Topic: Email Script Help  (Read 1609 times)

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9480
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #15 on: February 19, 2019, 05:53:07 PM »

I'm not sure you want a email for every open close event, maybe just an open event?
I've been playing with this code a bit as I feel it may be of use for some things and expanded on.
I can get this to send emails to any device in HG that has the option selected, including Door/Window sensors.
However I get 3 or 4 emails at a time so I still need to tweak it a bit.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 928
Re: Email Script Help
« Reply #16 on: February 19, 2019, 06:51:00 PM »

I do not want it to email every door open or close;  I have a test DS10 on my desktop to use as tester.  When finished it will be triggered by TAMPER (I think this reports quicker than door open & causes SC1200 to trigger alarm even if activity monitor does not show door open.  Anyway, it will be triggered by TAMPER *AND* ARMED.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9480
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #17 on: February 19, 2019, 07:10:39 PM »

OK, I understand but I'm not sure the Tamper reports quicker then an open.
However I've never played with that enough to be sure.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 928
Re: Email Script Help
« Reply #18 on: February 19, 2019, 07:56:45 PM »

How does one know if email is functioning in HG?  my log shows ZERO comment with the word email, my email address, my smtp server, anything!  yet under programs-social there is the email thing with green light on it.

I do not think it is working
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9480
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #19 on: February 19, 2019, 08:06:01 PM »

Does my program work and send a email if you enter the info?
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9480
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #20 on: February 19, 2019, 08:10:42 PM »

Since your using a pre-release PiX10Hub version and if you haven't done a update/upgrade when installed or even since installing that beta, that could be your issue.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 928
Re: Email Script Help
« Reply #21 on: February 19, 2019, 08:15:11 PM »

IIRC updating to stable.37 a week ago did update and upgrade as part of it...   

I just found both yours and my email programs red circle;  they need to be disabled and then enabled again!  then they went yellow!  and i am back to them going green for .2 sec when widget pushed.  No email tho and no code in the log.

but but but!  THANKS!  since it slowed down today I replaced my SD card with last backup...  it is old stable v1 572!!!

so tomorrow I will update to the new version put up tonight!  that will get upgrade/update again.

gosh, so easy to go backwards!
Logged

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 928
Re: Email Script Help
« Reply #22 on: February 19, 2019, 08:17:52 PM »

I also just found that both your and my startup code in the hgx is gone!  probably an old HG version bug... 
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9480
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #23 on: February 19, 2019, 08:18:35 PM »

IIRC updating to stable.37 a week ago did update and upgrade as part of it...   
But your still using a beta PiX10Hub image
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 928
Re: Email Script Help
« Reply #24 on: February 20, 2019, 10:18:08 AM »

IIRC updating to stable.37 a week ago did update and upgrade as part of it...   
But your still using a beta PiX10Hub image

But other than you changing directories around, how is my older beginning image not as good as what you promote today?  I believe we both use the same programs with the same updates?
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9480
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #25 on: February 20, 2019, 10:33:53 AM »

There were other things done with the initial boot besides moving directories for HG.
Do you know what beta or RC test your running?
Beta versions usually contain bugs which can affect other things.
It is not good practice to try and run a Beta build for regular use.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 928
Re: Email Script Help
« Reply #26 on: February 20, 2019, 10:49:58 AM »

I agree running beta programs when newer stable versions are available is not wise.  But I do not believe I am running any beta programs.  My HG is upto date with latest Gene build.  Doing his automatic update in HG maintenance page includes update and upgrade so all raspberry pi programs are also updated at the same time.  My HAbridge is a non beta working version that does its job flawlessly so I see no reason to change its version.  You added the start screen menu when opening a putty window;  that does not bother me as I know how to tab to finish and close it when I want to talk to the pi.

What am I missing?
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 265
  • Posts: 9480
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #27 on: February 20, 2019, 11:03:23 AM »

Sound like your running Beta 2.
If you feel the image is work for you, I 'll not try to explain all the image differences.
However if programs are not located where the author designated them to be many things possibly will not work as coded.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 928
Re: Email Script Help
« Reply #28 on: February 20, 2019, 11:04:27 AM »

ah, ok. 
Logged

bkenobi

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 18
  • Posts: 1746
Re: Email Script Help
« Reply #29 on: February 20, 2019, 11:23:23 AM »

the update/upgrade has nothing to do with a HG update.  You need to run an ssh session and run the update/upgrade commands.  HG may be updated but the reason email stops working is the certificates mono uses becoming out of date.  Update/upgrade will resolve this.  It will happen around every 2-3 months.
Pages: 1 [2] 3 4 5
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.