Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Pages: 1 ... 3 4 [5]

Author Topic: Email Script Help  (Read 1185 times)

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 264
  • Posts: 9424
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #60 on: February 21, 2019, 05:02:07 PM »

Wow! That was simple enough, and no dizzy spell  rofl.
Now to test everything during night and day. ::) :'
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 900
Re: Email Script Help
« Reply #61 on: February 21, 2019, 07:38:45 PM »

You Are amazing!   I will learn from this and challenge you more often!   :)
Logged

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 900
Re: Email Script Help
« Reply #62 on: February 21, 2019, 07:39:43 PM »

Do you think if I download your latest Sd image it would send email for me too?
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 264
  • Posts: 9424
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #63 on: February 21, 2019, 07:51:09 PM »

You Are amazing!   I will learn from this and challenge you more often!   :)
rofl Well I finished testing and all works as I designed (may not be how others wish it to perform) now to clean and polish up the code.
Do you think if I download your latest Sd image it would send email for me too?
The latest image may fix your issue as HG is where Gene designed it to be and it is locked to a mono version which is suppose to solve the email issues bkenobi references.
However since the consensus was to remove HA-Bridge from the image that is no longer on it, but you should have no problem installing it following the set by step I posted here  http://forums.x10.com/index.php?topic=30440.msg175106#msg175106
 you will need to be sure Homegenie is not on port 80 prior to installing HA-Bridge
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 900
Re: Email Script Help
« Reply #64 on: February 22, 2019, 08:58:02 AM »

I'm pretty sure my mono is the same one from your image so I doubt that is the issue.

 mono --version
Mono JIT compiler version 5.4.0.201 (tarball Fri Oct 13 22:19:03 UTC 2017)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       normal
        Notifications: epoll
        Architecture:  armel,vfp+hard
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen (concurrent by default)
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 264
  • Posts: 9424
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: Email Script Help
« Reply #65 on: February 22, 2019, 09:35:23 AM »

yep, I wasn't sure you stuck with it or were on the latest build.

I posted my Smart_E-mailer program as I got it all cleaned up and tested with different devices.
http://forums.x10.com/index.php?topic=30881.0
 >!
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 900
Re: Email Script Help
« Reply #66 on: February 22, 2019, 03:30:36 PM »

Just to make sure you completed all the steps, did you set up certificates for your specific email host?

I don't have my install script in front of me, but part of the setup process is getting certificates set up.  I believe the line you need to verify is:

Code: [Select]
certmgr -ssl smtps://smtp.gmail.com:465
I know I've posted the script somewhere, but don't remember which forums.  It's at home and on my flash drive (which is at home).  The command above was found by asking google about "raspberry mono certificate gmail" in case you need more info.  My script also has a line that can be used to test if the certificates are correctly installed, but I don't recall what that command is.  Google should be able to help.

If you could find your post on this and post it here I would be forever grateful!
Logged

bkenobi

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 17
  • Posts: 1695
Re: Email Script Help
« Reply #67 on: February 22, 2019, 05:00:45 PM »

Was sick last night and spent a few hours shivering under a blanket.  Will try to get to it this weekend.

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 13
  • Posts: 900
Re: Email Script Help
« Reply #68 on: February 22, 2019, 07:42:18 PM »

Hey bkenobi get well first!   I can wait!  I hear the flu is going around strong this year!  Stay warm and get better!
Logged
Pages: 1 ... 3 4 [5]
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.