Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Pages: 1 2 3 [4] 5

Author Topic: 📧HG Smart E-mailer  (Read 2398 times)

bkenobi

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 19
  • Posts: 1763
Re: HG Smart E-mailer
« Reply #45 on: March 25, 2019, 04:46:10 PM »

All RF codes (even if encrypted) are basically insecure as all a bad guy need do is capture the code and then replay it as is being done by the latest car thieves. The only RF codes that are reasonably secure are the rolling codes used with garage door remotes.

I've read that it's possible to defeat rolling codes too if someone is dedicated enough to build a jammer that can save the first code sent and require the operator to send a second one.  The first is saved for later use by the criminal since the door never heard it thus making it still a valid signal.

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 266
  • Posts: 9544
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: HG Smart E-mailer
« Reply #46 on: March 27, 2019, 06:40:10 AM »

The smart emailer was just updated to fix issues with sending times for armed/disarmed see post #20 for the link. ;)
http://forums.x10.com/index.php?topic=30881.msg181710#msg181710
@mike this is the version you were testing so no need for you to update.
 >!
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: HG Smart E-mailer
« Reply #47 on: April 03, 2019, 10:27:42 AM »

Just wanted to report back that the smart emailer is working wonderfully!  I have it set to only send email when security device triggered AND alarm is ARMED.

Yesterday when I left my office I bumped my TEST DS10 sitting on my desk, opening it...  it is a module in HG for testing but not in my actual X10 alarm.

Promptly after the alarm was armed last night, and every hour on the hour thereafter, I was sent an email stating the TEST DS10 door was open!  Until the alarm disarmed this morning and the hourly emails stopped.

SWEET!

Logged

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: 📧HG Smart E-mailer
« Reply #48 on: April 07, 2019, 03:27:44 PM »

Now that I had HG stop talking to my HAbridge, and not wanting to loose everything since only  my old non mart-email backups worked again, I updated to latest HG version and got HG talking to HA again, and smart email installed and most parameters manual put back in.  2 hours.  Only thing not working now is:  smart emailer.  Yes, it calls itself properly when sensor seen, but fails - due to JKutil not populating dusk/dawn info.   I tried 3 other API keys i have, not seem to work properly;  Looks like all times are London, UK.  I cannot seem to make an API key to show my location. 

Any clues where I should look next?
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 266
  • Posts: 9544
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: 📧HG Smart E-mailer
« Reply #49 on: April 09, 2019, 01:36:23 PM »

Configure/Settings/JKutil-Solar Altitude/options set your latitude and longitude
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: 📧HG Smart E-mailer
« Reply #50 on: April 09, 2019, 02:52:22 PM »

Configure/Settings/JKutil-Solar Altitude/options set your latitude and longitude

I do recall setting those in the past...  but there is noplace to set them now!  the options does not offer place to enter them.  I assumed having them entered on HG maint page should be sufficient but obviously not.

I assume your smart emailer is looking for verification long/lat numbers are entered in jkutil and not seeing them is reason it is failing to run. 

the default ones in jkutil somewhere are sufficient to give UTC values for all the parameters.  Not sure why smart email is not happy with these Greenland values...
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 266
  • Posts: 9544
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: 📧HG Smart E-mailer
« Reply #51 on: April 09, 2019, 03:05:45 PM »

Remember you need JKutil-Solar Altitude not JKutil-OpenWeather Data there is a difference
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: 📧HG Smart E-mailer
« Reply #52 on: April 09, 2019, 03:18:56 PM »

hahaha!  Time for me to use your head knocker!    http://forums.x10.com/Smileys/default/headbanging.gif

You probably solved it!   Yes, I am now the proud owner of Openwheather data one, NOT solar!

HG newest version update replaced it unbeknownst to me!   Was interesting to watch the latest HG installer/updater work:  it DELETED most of my programs then INSTALLED them later again.  Guess Gene's list did not keep track that I had solar and instead put back openwheather one!

THANKS yet again!
Logged

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: 📧HG Smart E-mailer
« Reply #53 on: April 09, 2019, 03:26:15 PM »

Can't find where I downloaded JKutil-solar Altitude from...
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 266
  • Posts: 9544
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: 📧HG Smart E-mailer
« Reply #54 on: April 09, 2019, 03:29:56 PM »

 configure/maintenance/Package manager
then scroll down to weather and environment click on Solar Altitude then install package
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: 📧HG Smart E-mailer
« Reply #55 on: April 10, 2019, 08:52:04 AM »

Thanks again.  That fixed it.  I am now on ver v1.3-beta.2 and all is back to working.
Logged

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: 📧HG Smart E-mailer
« Reply #56 on: April 10, 2019, 12:12:24 PM »

haha...  That fixed YOUR smart emailer program, it did not fix actually sending email.  Your program says "email sent" but no email arrives.  I have a quick email tester program, it says no email sent.  My gmail account shows no email  sent either.  I have re-entered email parameters into HG email program (from screen shot of WORKING HG) and it still does not work.  So it appears this new HG fw update has broken the email send capability at least for now.   I have not had time yet to go to the log to see if it gives any clue why.  maybe tomorrow will have time...
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 266
  • Posts: 9544
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: 📧HG Smart E-mailer
« Reply #57 on: April 10, 2019, 12:54:09 PM »

It is possible the beta HG messed with your settings I know I totally lost all my settings at my off grid place.
One RPi here got totally screwed while the other updated with out any issues. B:(
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

mike

  • Hero Member
  • *****
  • Helpful Post Rating: 14
  • Posts: 929
Re: 📧HG Smart E-mailer
« Reply #58 on: April 11, 2019, 09:40:45 AM »

not lost; they were still populated with my correct values.  I am afraid it is again a case of HG ignoring the entered data if not a totally fresh install.  I have not had time to go look at the log yet to confirm...
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 266
  • Posts: 9544
  • I don't work for X10, I use it successfuly!
    • Tuicemen Software
Re: 📧HG Smart E-mailer
« Reply #59 on: May 17, 2019, 07:14:07 AM »

Since day one of my HG use I had emails sent to me which contained 3 pictures each from 3 IP cameras with an alarm trip. Since all my cameras had pre set capabilities I soon created a script to turn them. With the current Pro IP camera addon ( http://forums.x10.com/index.php?topic=30983.0 ) I can move to presets and take a snapshot emailing that to me.

 My thinking now is to some how add the move camera and send picture to Smart Emailer. This would eliminate several scripts i currently use and eliminate the need to create more if I add a new camera.
 
« Last Edit: May 17, 2019, 08:06:15 AM by Tuicemen »
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum
Pages: 1 2 3 [4] 5
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.