Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Author Topic: HG will not restore backup correctly  (Read 733 times)

LostDog88

  • Hero Member
  • *****
  • Helpful Post Rating: 1
  • Posts: 170
HG will not restore backup correctly
« on: October 09, 2019, 10:01:04 AM »

I followed the instructions and easily got HG installed on the newest version of Raspian.

My problem is restoring the backups. When I do all my modules come back. So do the schedules. That is where the problem is. Scheduler doesn't work. If you try to see them in calendar view the wheel just spins forever. I go to edit events and I can see them. But when I click them and try to edit times etc, everything seems to work. After the save, the wheel just spins forever. Tried restoring the backup multiple times. No Joy. Tried different backups. No Joy. Scheduler will not work. Even though I see the items in there.

Any help is greatly appreciated.
Logged

bkenobi

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 20
  • Posts: 1865
Re: HG will not restore backup correctly
« Reply #1 on: October 09, 2019, 11:34:56 AM »

I haven't updated in a long time, but my recommendation is that if it doesn't work, don't force it.  Go and record your automation settings and start from scratch with a new SD card (keep original as a backup in case you need a reference).  For a large setup, this is a pain, but it should insure a smoother transition in the long run.  If you really need to restore a backup (which would be understandable for larger setups), I'd go to the HG club forum and ask there.  They are the HG experts and should be referred to for any HG related questions.  If it's a functionality question, it might be better to open an issue on the HG github page.  But, I don't know if Gene is on hiatus again or not so not sure of the timeline for his support.

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 20
  • Posts: 1464
Re: HG will not restore backup correctly
« Reply #2 on: October 09, 2019, 05:13:57 PM »

I followed the instructions and easily got HG installed on the newest version of Raspian.

My problem is restoring the backups. When I do all my modules come back. So do the schedules. That is where the problem is. Scheduler doesn't work. If you try to see them in calendar view the wheel just spins forever. I go to edit events and I can see them. But when I click them and try to edit times etc, everything seems to work. After the save, the wheel just spins forever. Tried restoring the backup multiple times. No Joy. Tried different backups. No Joy. Scheduler will not work. Even though I see the items in there.

Any help is greatly appreciated.

Just to clarify what installation instructions did you follow and what version of HG and Raspbian did you end up with. As bkenobi stated for more detailed support try posting on the HomeGenie Club forum. My own personal recommendation is HG v13 r5 installed on Raspbian Buster.
Logged

LostDog88

  • Hero Member
  • *****
  • Helpful Post Rating: 1
  • Posts: 170
Re: HG will not restore backup correctly
« Reply #3 on: December 21, 2019, 10:13:57 AM »

I never really researched this, however this is my opinion of what happened.

The restore I was trying to do was for an upgraded version of HG running on the new version of Pi. Buster I believe is what they call it.

Seems to me that I was trying to force to many upgrades going down the wrong path. I probably in hindsight should have installed the older version of the OS and then the older version of HG then upgraded. You know the proper way. LOL.

In any event, I just simply created another SD card image. Put on HG, redid all my schedules and success.

Then immediately created a backup including a clone of my SD card.  ;)
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.