Please login or register.

Login with username, password and session length
Advanced search  

News:

The Buster PiX10Hub is here! Created by the Community, for the Community.:)% #:)

Author Topic: SC1200 display problem  (Read 285 times)

cscjjd

  • Full Member
  • ***
  • Helpful Post Rating: 0
  • Posts: 34
SC1200 display problem
« on: September 25, 2020, 03:44:41 PM »

Hi,

one line of my SC1200 display has become unreadable.  For example, you cannot read the words "Home Control" (you can only see part of each letter) but you can read the next line (the time of day).  Is this curable?

Thanks!
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 292
  • Posts: 12840
Re: SC1200 display problem
« Reply #1 on: September 25, 2020, 06:32:03 PM »

Mine did the same thing.
I got to only a few small sections even displaying. Could not even guess what was being displayed.
I did not investigate too much further.
I wounder is it maybe the contacts connecting the display to the main board.
Maybe someone has some information on a possible repair. You and I may get some help.
Logged

cscjjd

  • Full Member
  • ***
  • Helpful Post Rating: 0
  • Posts: 34
Re: SC1200 display problem
« Reply #2 on: September 27, 2020, 02:37:58 PM »

Hi Brian,  sorry to hear you're having the same problem It's nice not to feel alone though.  Thanks!
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.