Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: FYI - Smart Video Macros  (Read 7004 times)

raym

  • Sr. Member
  • ****
  • Helpful Post Rating: 0
  • Posts: 119
FYI - Smart Video Macros
« on: October 22, 2005, 01:01:05 PM »

Hi,

I have some 'smart' macros set up to capture
video on X10 events. The macros will usually
work well. I find that if I use my computer
a lot the macros will fail more often. They
will eventually fail. I can always recover
by 'downloading timers and macros'.

I have macros set up to record video on an
X10 event.

ex (in my own language):

X10 event happens
check for flags
if flag (is set) exit
if flag (is not set) then set flag
send X10 command // starts video capture
delay for xx
send X10 command // stops video capture
clear flags
// - end of macro

When the macro fails, I can watch the flags
being set and reset in the 'file->reports-
>status' function of AHP. The flags are
getting set and reset (so I know the macro
has run) but the part where it should send
an X10 command never happens. I have tried
inserting delays between steps without any
luck.

I hope X10 can, one day, fix this.

Out of desperation, I opted for a hardware
capture device with the motion detection
built into the board.

Regards to all.

Ken



Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.