Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: Never buying X10 products again!  (Read 10421 times)

mtartaglia

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 3
Never buying X10 products again!
« on: March 30, 2006, 02:47:36 PM »

I have had several WS467 switches either physically break (due to normal use) or just fail to work.  In the past I was able to get a replacement pretty quickly and all times was just told to throw the old one away.  Now I am two more switches that do not work anymore, I paid for the extended warranty (they are not even a year old yet) and now I have to pay for shipping. 

Customer service doesn't seem to care about the customer any more.  Why have the polcies changed, you were doing so good?

Regardless, I am going to cut my losses and remove all my x10 home automation stuff from my house. 

Logged

nklght

  • Sr. Member
  • ****
  • Helpful Post Rating: 2
  • Posts: 126
Re: Never buying X10 products again!
« Reply #1 on: May 10, 2006, 01:13:09 AM »

I had my CM15A shoot craps over a week ago, and after jumping threw hoops, they finally determined the unit was defective.  By the time they receive my unit and ship me a new one I will probably go a month without the system operating.  I find that to be unacceptable, for any company.  I rely on a piece of equipment to run this system and it has been down for over a week.  Tech support should be available 24/7, so when I have an issue with a piece of equipment on Friday evening, and I can't get things in motion that night or the next day  I should not have to wait till Monday for help.  I don't believe that they actually read the e-mails sent to them,  I sent them a message explaining what happened and what I had tried to remedy the problem, and I would get an e-mail the next (tech support working day) to try something that I had already informed them that I did.  Then I would let them know that it didn't work, then I would be asked again to try something that I informed didn't work.  Finally, my last Tech Support guy person sent me an e-mail that I am close to get an RMA, but try this and see if it works, I tried it again and sent him an e-mail.  Eventually, after a week of doing everything that they want you to do, and reporting back (even though you sent them a message of everything you tried with nothing working, they basically want you to do everything over again.) that it still doesn't work, you will get an RMA.  I have dealt with several electronic companies during the years, and X-10 has one of the worst tech support available.  I have had hard drives go bad the company will send me an advanced RMA, which is they send me a new one as long as I provide them with a credit card number, and I will not be charged as long as they receive the old hard drive within 90 days of receipt of the new hard drive.  I have had a video card with a cooling fan go bad, they wanted the card sent back in order to fix the fan, I told them that if I had to send them the card, then I would go to different company for a graphics card, and would tell everyone I knew that they were a bad company to deal with, since if they wanted the card I would have to buy one to use while the card was being repaired.  I asked them to send me a new cooling fan, since it was easy to change, and I would ship them the old cooling fan, two days later I received a new advanced video card for no charge with letter attached asking for my old video card and thanking me for my patience.  I had a motherboard stop recognizing IDE devices, I called them up and told them the problem, I had a new motherboard the next day, with no request for the old motherboard.  X-10 needs to realize how important customer support is and allocate funds for it, my experience showed me that they do not read the e-mails sent to them and just send automatic replies with suggestions asking for replies, and after receiving several responses of this doesn't work, then an RMA will be issued.
Logged

dave w

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 136
  • Posts: 5959
Re: Never buying X10 products again!
« Reply #2 on: May 10, 2006, 12:32:31 PM »

FWIW $.02

Because so many things can effect the X10 signal as it is transmitted over home power lines, there are  many factors which will make the customer think it is an X10 equipment problem and X10 Inc. is responsible to fix.

Conversly,  X10 Inc may think it is an X10 environment problem (poor phase coupling, noise on the lines, etc) which they have little control over, other than to make the cutomer aware of the possible issues and help the customer trouble shoot from his end, before assuming the equipment is bad.

I find X10 Support,  responsive, given the obstacles they have to work around. It is not as "black and white troubleshooting" as "my fan don't turn anymore". Hence the possible reluctance take back equipment until all avenues of problem identification have been traveled.

However in strong defence of the customer, X10 Marketing implies X10 automation, cameras, security, etc is "Plug N Play".  Well, in 1981 it was. However, it ain't by a LONG shot anymore (U listening X10?).

I think it would be helpful if X10 begins better explaining, in the product instructions, the symptoms to look for in identifying noise and coupling problems. Would also be desirable for X10 to routinely "suggest" the use of a coupler repeater in most average size "home" applications. Again, a decade ago this was not needed, but with switching power supplies becoming cheap and prevalent, X10 noise problems will continue to escalate.

X10 has got to be the most inexpensive remote control systems available. That is also probably true of the X10 video and security products. However it comes at a price, such as not offering 24/7 phone tech support and "no questions asked"  product exchange. 



Logged
"This aftershave makes me look fat"

nklght

  • Sr. Member
  • ****
  • Helpful Post Rating: 2
  • Posts: 126
Re: Never buying X10 products again!
« Reply #3 on: May 15, 2006, 12:54:00 AM »

I would think that if they read the e-mails and what had occured they would issue an RMA instead of requesting me to try to different things, which did not work.  I told them that I used the remotes to shut off some lights the night before, the next morning none of the macros worked, and the unit would not respond to remote commands or AHP commands.  I had changed nothing electrical,  when I hooked it up to the computer it showed that it was running on the battery backup, although it was plugged into a live outlet.  Instead of issuing an RMA, they had me reconnect the unit to the computer, move the unit to a different outlet, and finally issued an RMA.  I have not been able to use X-10 for two weeks now, and I am waiting for my replacement cm15a.  During this time I have been looking for alternatives which will work with my X-10 system.  If the unit works fine with minor glitches (RF range and macros) and nothing changed on my end, then when it stops working, then something is wrong with the unit.  Another clue, to the techies of a bad unit, is the fact that it was running on the back up batteries, I used 16 batteries trying to troubleshoot the problem.  X-10 needs to revamp its tech support, to help people which truly have an issue with a piece of equipment, instead of making us jump through hoops. 
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.