Please login or register.

Login with username, password and session length
Advanced search  

News:

The X10Hub (PiX10Hub) is here! Created by the Community, for the Community.:)% #:)

Author Topic: Problem connecting to Webview using multiview.x10.com  (Read 29631 times)

ProblemChild

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 1
Problem connecting to Webview using multiview.x10.com
« on: August 23, 2006, 08:28:26 PM »

I just purchased an x10 package, which included 4 cameras with their appropriate hardware and software (multiview and webview). I was able to install the multiview software with no problem, but in reference to the Webview, I have been , for three days now, troubleshooting and trying all suggestions that have been emailed to me by the x10 support group. At this point I feel frustrated and disappointed with the level of phone support x10 is willing provide their customers. Nevertheless, while I wait for the email from one of the x10 senior techs.,  I was wondering if any of the forum members has experience the same problem and can shine some light on this direction.

PROBLEM:
I’m getting the following error message every time I try to access my cameras using multiview.x10.com;  “Error Occured: Can't connect socket: Operation timed out”  I have a DSL connection going through a D-Link router. I have opened router ports 8080 and 8888 as suggested, and have also changed password several times. The webview log shows “Webview is connected with multiview.x10.com”. I know this problem has happened to other end-users but I have not been able to find whether they have solved the problem and more important is HOW they did it.

Thanks  …
Logged

dragin99

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 5
Re: Problem connecting to Webview using multiview.x10.com
« Reply #1 on: January 04, 2007, 07:13:36 PM »

Noticed that this is an old post but was relevant to me so I figure others will have this problem and need the solution.
Firewalls and routers seem to be a major problem for the Webview app.
The key is not just forwarding ports 8080 and 8888...which you must do.
But the PC you are using to access the remote Webview server MUST have a static ip. Most people are using DHCP ( automatic ip address configuration ) especially those using a wireless connection in the home, so its easy to overlook this point.
Its not that tough to do but for newbies its a pain. This is why no one has a problem using webview when bypassing their router and going directly to the cable/DSL modem ( an even bigger pain and much more dangerous securitywise ). Anyway make sure you use a static ip outside the range of your DHCP server ...most routers block off 100-199 ( i.e. 192.168.1.100 - 199 ) just use one below 100 and you'll be alright. Don't know why the tech support boys don't have this on page 1 of their handbook when asked this question. They always tell you opening the ports should do it.
FYI the information is in the wiki knowledge base but you have to dig to get it.
Happy New Year!
Logged

dragin99

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 5
Re: Problem connecting to Webview using multiview.x10.com
« Reply #2 on: January 05, 2007, 02:41:13 PM »

Almost forgot...another quirk with home routers ( wireless or standard ) for some reason after you make the configuration change to static IP on your PC it takes a while to propagate through your network even if you power reset the router ( not just rebooting as required after you input the ip forwarding info ). I'm sure its a Microsoft thing because I never see this problem with linux based networks running windows. Anyway thought I should mention this, as it can be frustrating after you make these changes and are still unable to access your surveillance server (webview) and I'm not aware of a way to speed up the process...just be patient these changes will work.
P.S. I'm sure you've already discovered it only works through IE and won't work through Firefox( my browser of choice ).
Chow!
 
Logged

-Bill- (of wgjohns.com)

  • Advanced Member
  • Hero Member
  • ******
  • Helpful Post Rating: 81
  • Posts: 1340
  • He's just this guy. You know?
    • wgjohns.com
Re: Problem connecting to Webview using multiview.x10.com
« Reply #3 on: January 05, 2007, 10:31:18 PM »

Almost forgot...another quirk with home routers ( wireless or standard ) for some reason after you make the configuration change to static IP on your PC it takes a while to propagate through your network even if you power reset the router ( not just rebooting as required after you input the ip forwarding info ). I'm sure its a Microsoft thing because I never see this problem with linux based networks running windows. Anyway thought I should mention this, as it can be frustrating after you make these changes and are still unable to access your surveillance server (webview) and I'm not aware of a way to speed up the process...just be patient these changes will work.
P.S. I'm sure you've already discovered it only works through IE and won't work through Firefox( my browser of choice ).
Chow!
 

Windows seems to keep IP settings for a set period of time.  In my experience, you can override this by opening a command window (DOS box) then type in...   ipconfig /release   ... wait for it .... then type in...   ipconfig /renew

Hope that helps.
Logged
-Bill- (of wgjohns.com)
bill@wgjohns.com

In the real world, the only constant is change.

When I'm online you can find me in the Home Automation Chat Room!

alexkoch

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 3
Re: Problem connecting to Webview using multiview.x10.com
« Reply #4 on: May 29, 2008, 04:29:02 PM »

This configuration will require the following:
1. Set the IP for the internal (lower) router as static and different from the "upper" router (combined w/modem). For example: upper: 192.168.1.1 lower 192.168.1.2
2. Forward X10 ports on the upper router to the lower one (for this operation, connect PC directly to a the modem since IP 192.168.1.1 is "invisible" from under the lower router.
3. Connect the lower router to the upper router.
4. Connect PC to the lower router and set a static IP address on your PC (network->properties->TCP/IP->properties->set IP addr like 192.168.1.36 (do not obtain automatically!)
5. Check this addr is not in DHCP range or completely disable DHCP on the lower router).
6. Forward X10 ports on the lower router to your PC (192.168.1.36).
7. Start Multiview then WebView. Start sharing images etc.
Hope this helps. I have a similar configuration (2 routers, 4 wireless cams, 6 switches, wireless network) which works almost 3 years.
« Last Edit: May 29, 2008, 04:42:04 PM by alexkoch »
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.