Please login or register.

Login with username, password and session length

Author Topic: Power outages reset WM100 clock. WORKAROUND  (Read 1235 times)

HomeAutomat[999]

  • Newbie
  • Helpful Post Rating: 0
  • Posts: 1
Power outages reset WM100 clock. WORKAROUND
« on: May 24, 2024, 02:45:31 PM »

As I'm sure just about everyone who uses the WM100 Wi-Fi module knows, it does not include a battery backup for its internal clock.
You can overcome this flaw if you put the WM100 on a UPS that will permit the WM100's signals to cross back into the outlet into which the UPS is plugged.
I have numerous X10 modules that I use in my home's automation system, and I discovered this vexing problem only after a power disruption.
I decided to try using an old UPS that I brought back online for use with the WM100 specifically. While this is not the best solution, since this is CLEARLY a design flaw in the WM100, I have been testing it for a week and it has resolved the issue with the time-loss. I have not tested to determine whether the frequency of the power supplied OUT of the UPS affects the timer in the WM100 over the long term. I have repeatedly cut/restored power to the UPS and the WM100's LED remains steadily illuminated, the WM100 functions normally afterward, and it appears to be keeping the time synced as set from my cell phone. I have repeatedly checked the WM100's "History and settings," and the timing of the ON/OFF signals to the other X10 modules remains as I set it.
« Last Edit: May 24, 2024, 02:51:36 PM by HomeAutomat[999] »
Logged

Brian H

  • Community Organizer
  • Hero Member
  • ***
  • Helpful Post Rating: 305
  • Posts: 13270
Re: Power outages reset WM100 clock. WORKAROUND
« Reply #1 on: May 25, 2024, 06:10:50 AM »

Thank you for the information.
One thing that may effect the WM100 is the UPS used and the design of the WM100's power supply.
Many UPS units have a stepped or modified AC output on battery backup. You can find true sine wave UPS units but many still are modified output.
Depending on the exact model UPS output. The WM100 may not handle that signal well and act strange.
I an glad your was fine on the UPS and all seems to be fine with the setup.

Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.