Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 [2] 3 4

Author Topic: Net.WebService GetData() problem after Raspberry Pi update  (Read 2532 times)

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #15 on: May 30, 2020, 07:04:46 PM »

The JK utils program does not make an API call - it uses the latitude and longitude user defined values and then a bunch of math calculations to get the data.   The issue with the weather program is the API call does not have any data returned.

I'm going to try another API call in a HG program to something like ifttt when I get a min - probably tomorrow.  Something I want to play with anyway and I can verify if it may be an HG thing or just a weather API call issue.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 275
  • Posts: 10296
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #16 on: May 30, 2020, 07:17:28 PM »

The JK utils program does not make an API call - it uses the latitude and longitude user defined values and then a bunch of math calculations to get the data.   The issue with the weather program is the API call does not have any data returned.

I'm going to try another API call in a HG program to something like ifttt when I get a min - probably tomorrow.  Something I want to play with anyway and I can verify if it may be an HG thing or just a weather API call issue.
  actualy it does use the api & key, you maybe confusing the open weather program with the other jkutils program which does math to calculate dusk dawn.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #17 on: May 30, 2020, 07:23:57 PM »

Ahh, yes you are correct.  I don't have the JK utils weather program to look at however.
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1685
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #18 on: May 30, 2020, 07:42:52 PM »

Since I currently only have access via my phone it is difficult to  do much digging. However I was able to load the jkutils open weather version and it works so it would be worth looking into its code for comparisons.

You can restart OW program via the phone. Have you done this. What are you using for weather. Are you using the OW that comes as standard with HG. I don't use OW but am trying to help soxfan1966 troubleshoot his issue.
Logged

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #19 on: May 30, 2020, 07:50:31 PM »

Both the standard OpenWeather program and my version have the same issue.  I have confirmed that.  I do not have the same the JK utils weather program.   But I looked on GitHub and the version I saw there uses the same Net.WebService call as the other two programs.
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1685
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #20 on: May 30, 2020, 07:51:31 PM »

Ahh, yes you are correct.  I don't have the JK utils weather program to look at however.

I dont use jkutils but as far as I remember it stopped working a while back. It hadn't been updated in quite a while. I'm interested to see that it's still working now. Maybe @bkenobi might have a bit more detail on this. You've put a lot of work into OW recently so I'd like to see this problem resolved for you. If you haven't posted the OW code over on HomeGenie.Club it might be worth doing so. Remember it's not included in the HGBE version of HG.
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1685
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #21 on: May 30, 2020, 07:53:49 PM »

Both the standard OpenWeather program and my version have the same issue.  I have confirmed that.  I do not have the same the JK utils weather program.   But I looked on GitHub and the version I saw there uses the same Net.WebService call as the other two programs.

Yes thats why I was surprised to see jkutils was still working.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 275
  • Posts: 10296
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #22 on: May 30, 2020, 08:06:21 PM »

Both the standard OpenWeather program and my version have the same issue.  I have confirmed that.  I do not have the same the JK utils weather program.   But I looked on GitHub and the version I saw there uses the same Net.WebService call as the other two programs.

Yes thats why I was surprised to see jkutils was still working.
I was surprised to see it reporting correctly myself. I have no problem restarting OW what I was referring to was the inability to play with code sorry I wasn't  more clear.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1685
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #23 on: May 30, 2020, 10:04:10 PM »

Both the standard OpenWeather program and my version have the same issue.  I have confirmed that.  I do not have the same the JK utils weather program.   But I looked on GitHub and the version I saw there uses the same Net.WebService call as the other two programs.

Yes thats why I was surprised to see jkutils was still working.
I was surprised to see it reporting correctly myself. I have no problem restarting OW what I was referring to was the inability to play with code sorry I wasn't  more clear.

So youíre saying that the OW program is fetching updated forecasting for you. Thatís interesting. Youíre the only one reporting back that itís working for so far. When is the last time you did a system update system.
Logged

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #24 on: May 31, 2020, 06:06:59 AM »

Looked a bit again this morning.   The GetData() command appears to be defined in the HG code, which I can't see.  There is also a Get Bytes() command that is supposed to return a server code.  This from the helper doc:
https://genielabs.github.io/HomeGenie/api/ape/class_home_genie_1_1_automation_1_1_scripting_1_1_net_helper.html

However, that returns nil too.

Not sure what to do at this point.

Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 275
  • Posts: 10296
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #25 on: May 31, 2020, 06:38:22 AM »

@petera my HG included OW doesn't  update, it hasn't  since 6:41 am yesterday.
However the jkutils openweather program does update though not as accurate as Genes version was. Temperature is off by +3įC I'll have to sŤe if it is pulling from same station.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 275
  • Posts: 10296
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #26 on: May 31, 2020, 07:15:26 AM »

I managed to view the jkutils pull request and it does use net.webservice  getdata command as well but works, so  I believe there is something else at play here.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #27 on: May 31, 2020, 07:56:58 AM »

Over on GitHub, Gene looked into it and found the issue to be the certificate on the OpenWeatherMap side expired.  You can see the details here
https://github.com/genielabs/HomeGenie/issues/403
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 275
  • Posts: 10296
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #28 on: May 31, 2020, 08:00:47 AM »

I emailed OpenWeatherMap support to see when and if we can expect this  to be renewed.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1685
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #29 on: May 31, 2020, 08:29:28 AM »

As I suspected in my Reply #6 the problem appears to be a validation issue on the OW end. If any program stops working suddenly and so widespread it usually points to security certs issues. According to Genes reply to @soxfan1966 in the GitHub certs did expire on the OW end on May 30 so that would indeed confirm my suspicions. It's now a case of OW updating their security store. I have no doubt that other applications using OW as their weather source will flag this issue too. Maybe Gene as the author might alert them to the problem he is having with his application. For the moment it's a case of sitting back until OW resolve this issue.

@soxfan1966 I noted from your GitHub issue you are using HG 1.1 v527. While its not necessary to be running the latest version there's a number a features you are currently missing present in HG 1.3 v7. A number of them relate directly to X10. You can see what they are from the release change logs on the GitHub.
Logged
Pages: 1 [2] 3 4
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.