Please login or register.

Login with username, password and session length

Author Topic: HG netcore vs net461 question  (Read 134 times)

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 388
HG netcore vs net461 question
« on: November 06, 2022, 07:51:01 AM »

Good morning all,

Been awhile since I have been on here.  My HG version has been running pretty well lately - just periodic updates to the raspberry OS (not full upgrades, just updates to Buster I believe).

I do have periodic issues with the Smartenit device but unplugging the USB cable for a bit and then plugging back in seems to resolve that (there is a separate post around here somewhere on the Smartenit).

I subscribe to the GitHub for HG and have gotten several emails lately about some of the components being updated etc but the overall HG version is still v1.3-stable.19, which is what I am running.

Awhile back, there was some discussion from Gene about some sort of rewrite to HG - I cannot recall the specifics but I think it had to do with netcore, not sure if it was to or from that.

This morning, I posted a question on the HG GitHub site inquiring about this (here is the link to the question:  https://github.com/genielabs/HomeGenie/issues/448

Here is my question:
In the readme file for running HG, there is this info:
Running
netcore

cd src/HomeGenie/bin/Debug/netcore3.1
./HomeGenie # (or 'dotnet HomeGenie.dll')
net461

cd src/HomeGenie.Net461/bin/Debug
./HomeGenie.exe # (or 'mono HomeGene.exe')

The service I am running in my raspberry pi is using this:
/usr/bin/mono /home/pi/homegenie/HomeGenie.exe --log

I think that means I am running the net461 version, which I believe is the old/existing/current version, but I am not sure.

Is anyone running the netcore version or is that really not ready yet and what I am running is still the current / correct version?

Thanks
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 279
  • Posts: 10399
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: HG netcore vs net461 question
« Reply #1 on: November 06, 2022, 04:16:10 PM »

The net core version is still in 1.4 alpha 10 and will require a pi capable of running 64 bit I had  it installed on a new ZerroW2 and a pi 3B+ but haven't had time to play much with it on either one. I run the 1.4 alpha 10 dotnet on my loghome ZeroW setup and it works fine for the small x10 setup there, no issues with it. I plan to get back at playing with the net core version next month.
« Last Edit: November 06, 2022, 04:26:03 PM by Tuicemen »
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 25
  • Posts: 1733
Re: HG netcore vs net461 question
« Reply #2 on: November 07, 2022, 07:57:07 PM »

Rather than repeat here what I already stated on the GitHub in response to your question hereís the link. https://github.com/genielabs/HomeGenie/issues/448

Itís over a year and a half since the HG author did any development on what he termed his 1.4 Alpha of HG. I think itís safe to say HG users are not likely to see that situation change any time soon. Based on that if you want stability on your HG setup stick to whatís known as stable 1.3 v19.

The Homegenie forum is once again down and from reports itís not likely to return anytime soon either. Just keep your OS up to date. That should suffice.

Basically there is no real additional functionality beyond 1.3 v19 other than a half developed GUI which is woefully lacking at the moment. As for playing around with the Alpha, by all means fill your boots.
Logged
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.