Please login or register.

Login with username, password and session length
Advanced search  


Author Topic: Active Home Pro Install Problem - Solved  (Read 5443 times)


  • Newbie
  • Helpful Post Rating: 0
  • Posts: 1
Active Home Pro Install Problem - Solved
« on: June 30, 2005, 02:55:01 AM »

I received my Active Home Pro hardware
today, and went to install the software.  I
decided to wipe the computer clean I was
installing to - and I installed a fresh
copy of Windows 2003 Server.  ActiveHome
Pro was the first software I installed
after windows.  It would not work.  The "X-
10 Device Network Service" would not start
(under services in the Control Pannel), and
when I tried to start the Active Home
software itself, I got the error
Message "Error Getting X10Net Interface".

I am a Software developer during my day job
so I decided to check the dependencies of
all the EXE and DLL files that were
installed using a program called
DEPENDS.EXE (from www_dependencywalker_com).

Sure enough it was missing some basic C++
Runtime Files.  These are installed by just
about every other software out there, so
for most people they probably already have
the files.  (Since I had a new Windows
Installation - they were missing.)

The Files that were missing on my system


All I did was find these files on my other
computer, and copy them to
the "C:\Windows\System32\" Folder.

Then the service started, and the Active
Home program ran.

I thought I would post this message so that
anyone else having the same problem
wouldn’t pull their hair out, and if X10
reads this, they should update their
install procedure.

Logged | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 All rights reserved.