X10 Community Forum

🔌General Home Automation => Original ActiveHome => Topic started by: Dave4720 on May 11, 2011, 03:39:45 PM

Title: CM11A Macro Quirk
Post by: Dave4720 on May 11, 2011, 03:39:45 PM
Thought I’d post my problem and solution and see if anyone else ever had this issue, or can explain it.  Maybe I’ll solve someone else’s headache.

I have a CM11A working fine.  One macro controlled several modules individually, and then had two global entries at the end.  Worked fine for months.

Then I added a new, individual module, and added it to the macro.  The new module was not responding to the edited macro.

The entry on the Macro Summary printout showed the new module having the same ‘All Lights On’ and ‘All Units Off’ command as the global entry above - NOT a individual ‘ON’ or ‘OFF’.

Hmmm …

So I deleted the global entries, saved, exited, then edited the macro again to add the globals back in.

Then, all worked fine, and the individual ‘ON’ or ‘OFF’ commands were properly shown on the Macro Summary printout.

I’d guess that the CM11A does not like to have individual modules added after a global.  I had several macros with this same “disease”, and deleting-then-reinserting the globals (and therefore moving them to the end of the command list) fixed each one.

Just an FYI and I’m open to comments, explanations, or “hey, that happened to me too”.
Title: Re: CM11A Macro Quirk
Post by: fuzzmanks on May 11, 2011, 11:28:41 PM
That information is good to know. I do use one global command in two or 3 Fast macro's, but I'm not sure I ever edited by adding new commands.  I have however changed the delay times between the various commands included in a macro.

I'm about to move my Activehome software and CM11A from my XP machine to my Windows 7 machine.  Hopefully all will still work!