X10 Community Forum

🖥️ActiveHome Pro => ActiveHome Pro General => Software Problems & Bugs => Topic started by: branhamr on July 26, 2012, 09:36:18 PM

Title: AHP Tools bug
Post by: branhamr on July 26, 2012, 09:36:18 PM
Windows XP, AHP 3.318, CM15A
A few weeks ago, I ran AHP for the first time in several months and it wouldn't connect to the CM15A interface.  I don't remember exactly what the symptoms were (?) but I was apparently using an old version.  I updated, things worked and I finished the task.  Today I tried to open AHP but it failed to recognize the CM15A again.  I was mainly interested in troubleshooting some foreign signals which have been turning my bedroom light on occasionally at about 5:00 AM, so I activated the "Find Other Computers" function.  Instead of a normal window, I got what is apparently a one-pixel-wide "window" (you see a vertical line in the middle of the normal AHP screen, colored as though it were a single pixel cross-section of a regular window).  However it does nothing and locks AHP to the point I have to close it with Windows Task Manager.  The "Hardware Configuration" and "CM11 Configuration" functions display the same anomaly but with different height "windows" (still one pixel wide).  I tried to include an image of the screen but can't seem to make that work??(http://)

I have uninstalled and reinstalled from the current version of setup_AHP.exe.  Any ideas out there?  Has anyone else experienced this? 
Title: Re: AHP Tools bug
Post by: Noam on July 27, 2012, 11:43:38 AM
I think those secondary windows use IE as their display engine.
Try opening IE, and un-maximizing the window.
Make it fill a large part of the screen, and then close it.
Try AHP again.
Because AHP leaves some IE processes open even after you close it, you may need to use the Task Manager to kill all instances of iexplore.exe first (after closing AHP) before trying this.
Title: Re: AHP Tools bug
Post by: branhamr on July 28, 2012, 09:29:17 PM
Thanks for the answer, Noam.  I tried it, but no luck.

I started from a cold boot and opened, resized and closed IE per your instructions.  Two iterations of iexplore.exe showed up in Task Manager, but closed when IE was closed.  AHP opened two (new) iterations when I used the "Activity Monitor" function (which seems to work as it should) and leaft them open when the monitor window was closed.  Starting clean again (reboot, checked for open iexplore.exe, reran AHP), both "Find Other Computers" and "Hardware Configuration" still produce the one-pixel-wide window.  Neither one opens an iexplore.exe.

Another thing I noticed during this set of tests.  The narrow windows show a blue top (large) and bottom (small) area, sized just like the top and bottom blue margins of a typical windows window.  They respond to a click on the window with a change from light blue to darker blue, as if the "window" is changing color in response to getting and losing focus.  The narrow window also displays another AHP iteration on the taskbar.

Any other ideas?
Title: Re: AHP Tools bug
Post by: Noam on July 29, 2012, 09:57:32 AM
You might try this:
When you have the window selected, press Alt-Spacebar, which should pop up a menu. Choose "Size," and then use the arrow keys to make the window bigger. Press "Enter" to lock in that setting.
Title: Re: AHP Tools bug
Post by: Dan Lawrence on July 29, 2012, 04:24:11 PM
What I get is a window " X10 Code Usage - Historical." with symbols.  No use if IE at all in 3.310.
Title: Re: AHP Tools bug
Post by: branhamr on July 29, 2012, 07:29:37 PM
I don't get any pop-up menu at all in AHP.  Frustrating!
Title: Re: AHP Tools bug
Post by: Noam on July 29, 2012, 08:52:28 PM
The Alt-Spacebar is a Windows thing. It is supposed to bring up the little menu when you right-click the icon at the top left of a window.