X10 Community Forum

📱X10 WIFI => 🐞X10 WIFI App problems or bugs => Topic started by: adrian_tracy@yahoo.com on November 07, 2021, 12:33:58 PM

Title: Loss of connection
Post by: adrian_tracy@yahoo.com on November 07, 2021, 12:33:58 PM
Cannot get a connection to the WM100.  It worked.  Had a 4 day power loss due to storm.  Could not connect to HUB since.  Tried brand new (Amazon) HUB and new router.  Will not connect.  Internet connects (wired), several other wireless devices work OK.
Title: Re: Loss of connection
Post by: brobin on November 07, 2021, 05:55:02 PM
Are you saying you bought a new WM100 and new router and you still can't connect to the server?  And that your other WiFi devices, like your phone, can connect to the internet using WiFi?
If yes to both it sounds like the X10 server may be down and hopefully another user here will chime in.  Have you called X10 Customer Service to ask them?  They might be able to help.

This is where I always make my pitch to replace the WM100 with a far better product.

If you're having problems with the WM100 I'd like to suggest you return the new one to Amazon and spend just half that money for a Smartenit Harmony P2 and get everything the WM100 does plus Alexa/Google Home integration, real time clock and more.

As an almost 40 year user of X10 I was thrilled to be able to control my system with Alexa using a simple plug'n' play device that can also function as a full blown X10 controller.

The solution I'm using is a Smartenit Harmony P2 with a bundled Insteon 2412UPLM.  At $60 for both it's an economical solution that not only gives you Alexa skill supported control of X10 but an app and a sophisticated automation controller with email and text notifications.  I've been using it for almost 3 years and it's rock solid.  It's basically what X10's WM100 should have been but for half the price and better functionality.  It's virtually plug 'n play so you can be up and running 30 minutes after you open the box.  Everything is done through an Android/IOS app or web portal.  In addition to X10, you can also use it to control Insteon and ZigBee devices should you ever wish to. 


If you order be sure to click the selection to include the 'Add Insteon/X10 powerline only PLM.' bringing the total to $59.99.

Feel free to ask any questions.  A growing number of us here are using the P2 successfully.

Title: Re: Loss of connection
Post by: Tuicemen on November 08, 2021, 09:07:56 AM
Most new routers now are dual band and many default to using only 5ghz. Remember the x10 hub is only 2ghz.
The server is working currently here in (the eastern time zone)
Title: Re: Loss of connection
Post by: brobin on November 08, 2021, 09:15:37 AM
Excellent point T! I bet that's his problem.
Title: Re: Loss of connection
Post by: Goouch on May 04, 2022, 09:48:28 PM
I have the WM100 & it worked for years without any issues until a few months ago. I then also looked into the Smartenit Harmony P2 with the bundled Insteon 2412UPLM. But I got busy with this and that coming out of Covid & ended up dragging my feet my feet & was going to get around to it. Last week I decided to make the purchase only to find out it is now sold out. The web site instructs you to purchase the new Multi-Protocol Gateway/Hub 4-Core. One issue... for that device to work with X10 you're now spending almost $200, so on to dragging my feet again.

Anyway on to why I'm writing this. Just as I was about to take the plunge this week & purchase the Multi-Protocol Gateway/Hub 4-Core.. I accidentally discovered the problem we've been experiencing is not with the WM100, but with our phones software! I have been using an old Samsung S7 Active. As a restorations professional I always drop my phones, and the Samsung Active series are just what I need (Too bad they stopped at the S8 Active) but it's been dropped one too may times & I needed a quick phone fix. I had an old Apple S6 Plus in pieces that I had laying around & wanted to fix it one day to see what the Apple hub-bub is all about (yes I like old stuff, that's why I still use X10 :) but I never had time to put back together, but desperate times called for desperate measures. So I put it back together pronto, did a fresh OS install & as I was installing all my old Apps.. I decided for some reason to install the X10 App as I was trying to do what I thought was a fresh setup on the iphone it warned me that these devices were already assigned. "CRAP!" I said to my self... "This WM100  is a P.O.S!!" anyway I was giving up & as I backed out of the set up Vah-lah!! Not only does it work,  it was all there, EVERYTHING! With the names of everything just as I originally set it up on my old phone.

So in my conclusion I discovered it's something corrupted within our phones. I suggest backing up your phone, then wiping the phone & then reinstalling everything and it should be good to go. Or grab another phone in the house that did not have the app on it install the app & see if it works.

Good Luck
Title: Re: Loss of connection
Post by: brobin on May 05, 2022, 12:16:10 AM
FYI, Smartenit may be getting a small batch of P2's back in stock in a few weeks and then it will be gone forever leaving just the G2.  While the G2 has better specs than the P2, it makes no difference for X10 use.