X10 Community Forum

🖥️ActiveHome Pro => ActiveHome Pro General => Topic started by: poursha on February 09, 2006, 11:06:24 PM

Title: USB Problems
Post by: poursha on February 09, 2006, 11:06:24 PM
Ok, here is my setup, and problems I've
been having:

First off, I AM (or was) using an extension
USB cable.  I didn't want the CM15a on the
same plug as the puter.

Problems I've been having.  Sometimes I've
noticed that the Activity Monitor dies.
And, also, sometimes I push buttons and
macros inside of AHP, and nothing happens.
I use extrernal controls (remotes, etc..)
and the same macros work fine.

The fix...  I just unplug the USB, and plug
it back in.  Usually works.

Wondering if major part of my problem is
the USB extension.

Just tonight, I changed my setup to include
an extension CORD, instead of an extension
USB, and I went with the short USB.  Will
report back if this fixes totally.

Also, I'm pretty sure that I'm USB2.0.

Title: Re: USB Problems
Post by: Dan Lawrence on February 09, 2006, 11:17:13 PM
Any USB 1 ports on your computer? If you do,
swap a device with the 15 so it's on the 1.
X10 won't admit it, but the 15 doesn't like
USB2 ports for some reason. I've had to swap,
so has Bill (of BXVC). Strange.
Title: Re: USB Problems
Post by: tyryn on February 10, 2006, 12:56:32 AM
Rob may be able to prove the extension
problem if he happens to have a cheap 4 port
USB hub handy AND a known low speed USB
device such as a USB mouse.  Plug both the
mouse and the extension cable into the hub
and the hub into the USB2 port.  If I
remember correctly, the existence of a low
speed device on a USB segment will force the
hub to not transmit at the 480 Kbps (USB 2 )
Title: Re: USB Problems
Post by: neal on February 10, 2006, 01:20:04 AM
X10 techs seem to be missing any
comprehension capabilities here! I've tried
detailing the problem to them but they're
just totally dense or something.  I think
they understand the problem but just
haven't got a clue how to fix it. What a
load of crap, anyway. My suggestion is call
your local BBB or attorney general & file a
complaint - these ****s aren't going to
fix the problem until we find a way to
force them to stop selling this ****!
Title: Re: USB Problems
Post by: Brian H on February 10, 2006, 07:03:15 AM
Could also be noise. X10 hasn't used any
extra noise suppression it didn't need for
minimum protection. Some here have added 4
bypass caps to the power supply and IC chips
and their problem where gone.
Title: Re: USB Problems
Post by: arf1410 on February 10, 2006, 11:34:56 AM
so in other words Neal, you don't have a
strong opinion?

Brian H - I have heard about the capacitor
mod before, but I have yet to hear X10 Pro
make any comment about the need for this.
Has he commented to you? Has X10 ever made
a comment about the unrecognized USB device
issue - other than the "fix" of the battery
removal routine - which is a work-around,
not a fix?
Title: Re: USB Problems
Post by: X10 Pro on February 10, 2006, 12:24:39 PM
There shouldn't be any problems with the
CM15A and USB2 ports in general; I can maybe
see specific hardware having trouble.

Neal: Can you explain to me (here or in an
e-mail to ahpsupport@x10.com) the problems
you have had trouble getting technical
support to understand?
Title: Re: USB Problems
Post by: yznhmr on February 14, 2006, 03:28:28 PM
i had all kinds of weird problems with my
AHP...untill i put my AHP on a keyspan
usbserver( allows remote usb through cat5
cable ), plugged the AHP into an outlet
right next to my  breaker box, and
everytime i was done tinkering around with
the software on my AHP, i went into
services on my PC and shut down the
x10 "service".. my system has
worked "PERFECTLY" ever since...
no filters... no extra nothing..
it is now 100% reliable.. which i need as
my 330gal aquarium is connected to the AHP.
it runs my water top off , my lighting, and
various pumps...
Title: Re: USB Problems
Post by: andre on February 14, 2006, 08:46:13 PM
Hi guys,
I'm the person that came up with the 4
additional capacitors to be added to the
CM15A circuit board.  Everyone that has
applied the mod has done so because of
timers and macros that have ceased to
behave.  All units that have been modified
are rock solid stable.  Mine has been
running since last July.
USB problems may be related because one
of the symptoms is that the USB interface
doesn't work when the macros go stupid.
The mod is simple and takes about 10
minutes to implement.  You require 4 0.1uf
ceramic capacitors. Axial or radial or even
surface mount types work.  Apply them to
the following locations on the board:
one across C11, one across C12, one across
pins 1 and 8 of U2 the 24C64, and one
across pins 6 and 11 of U1 the CY7C63723
I would like to know if the USB problems
are solved by the caps.  USB 2.0 ports will
downspeed to match the capability of the
slowest device on the port, including
downstream of the hub.
Title: Re: USB Problems
Post by: john drummond on February 15, 2006, 11:55:39 AM
RoB Runkle's description of how his CM15A
operates is almost identical to mine, except
I can't make my unit ever go "good", even
unplugging it, removing batteries, etc.

The EXACT same unit worked fine on my
previous computer (using USB 1.0), but when
I upgraded computers and got USB 2.0, my
problems began.

I have traded a few emails with X10
support on this topic.  We have tried all
the usual things, like deleting, reloading,
powering down, pulling batteries, etc.  I
look forward to the response to my latest
email asking for further "experiments" to
fix my operation issue.
Title: Re: USB Problems
Post by: Noam on February 15, 2006, 02:56:01 PM
Rob -
This sounds very similar to what I have,
too. Does teh Activity Monitor just seem to
stop recording timer activity, with no rhyme
or reason? When that happens, does it still
record activity from "external" sources
(like hand-held remotes, or motion
detectors)? I have found, usually, that re-
downloading will make it work again, most of
the time. Anybody else out there have
something similar?
Title: Re: USB Problems
Post by: yznhmr on February 15, 2006, 09:01:11 PM
did you try stopping the service?
Title: Re: USB Problems
Post by: Noam on February 15, 2006, 09:43:38 PM
Stopping and restarting the service
sometimes fixes it, but it shouldn't break
in the first place.
Title: Re: USB Problems
Post by: yznhmr on February 16, 2006, 03:52:33 PM
i have found you have to leave the service
turned off if you leave the AHP module
attached.. unless you are doing some
programming.. or logging
Title: Re: USB Problems
Post by: poursha on February 16, 2006, 09:43:53 PM
Still screwing up.  The removal of the
extension USB seemed to work for a little
while, but nada.  Still screwed up.

Easy fix though.  Although it IS a pain in
the A$$ to have to unplug and replug the

I haven't paid much attention to the
Activity Monitor lately.  But, the break
down is obvious when the AHP won't respond
to ANY commands from the PC.  Most
everything still works (remotes, macros,
timers, etc..).  But, the PC communication
to the CM15A gets screwy.

It MIGHT have had something to do with me
pluging in my iPod in the USB right next to
the CM15A.  I noticed it was screwed up
after I had been away for a few days.
Then, I reset, and all good.  Then, just a
few hours later, it was screwed up again.
Only thing that I might have had an impact
is that I plugged in my iPod to charge.

Title: Re: USB Problems
Post by: poursha on February 16, 2006, 09:48:50 PM
Additional info:

I unplugged and replugged the iPod.  Did
NOT cause problems.

Also, I don't know if I mentioned before,
but when it does go screwy, and ignores the
PC commmands, I unplug and replug.  Once, I
replug the USB, it acts like it trys to
catch up.  Example:  If I tried to turn on
a light, and I turned it on and off,
several times without success.  When, I
unplug and replug the USB, it turns that
light on/off/on/off.  Like it is trying to
catch up.

Come on X10 guys.  I'm trying to help out
here.  Can't we fix this?

Title: Re: USB Problems
Post by: Noam on February 17, 2006, 10:28:10 AM
I don't have a problem with PC commands,
when this happens. They still work fine. And
the Activity Monitor still logs commands
from handheld remotes, and from motion
sensors (not that I have any motion sensors,
but it would still work). The only thing
that stops working, is the PC's
acknowledgement of any timer activity. It
doens't show up in the log, and x10Dispatch
doesn't see it, either. I know the timers
are still working, as the lights still go on
and off at the right times. (I have a second
CM15A on a second PC, acting as a backup to
ym Activity Monitor - It has no timers - it
just sits there watching the activity on the