Please login or register.

Login with username, password and session length

Author Topic: Heyu only works as root  (Read 7035 times)


  • Sr. Member
  • ****
  • Helpful Post Rating: 2
  • Posts: 116
Heyu only works as root
« on: June 01, 2012, 06:14:48 PM »

I just had to reinstall Ubuntu on my desktop after crashing it during an earlier upgrade. So I had to reinstall Heyu which was working perfectly before but now it only works as root if I put the sudo command before everything. Here's exactly what I did:

- downloaded newest Heyu
- unpacked to /home/heyu
- ./configure, make, make install
- tried to run heyu start but got an error about missing the /usr/local/var/tmp/heyu folder
- tried to create folder as user but didn't have permissions
- ran "sudo mkdir /usr/local/var/tmp/heyu" to create the folder
- tried again, now it complained about missing the /usr/local/var/lock folder
- "sudo mkdir "/usr/local/var/lock"
- tried again, it complained about no write access to the lock folder
- added write access to lock folder

Now when I try to run "heyu on c1" it reports "HEYU: Can't open tty line. Check the permissions."
If I run it with sudo in front it works fine and the light comes on. What have I done? Thanks.


  • Sr. Member
  • ****
  • Helpful Post Rating: 2
  • Posts: 116
Re: Heyu only works as root
« Reply #1 on: June 01, 2012, 06:32:49 PM »

Nevermind, I got it.

Code: [Select]
sudo adduser <username> dialout
and then restart to ensure the new group is picked up by the user. That will give them access to the tty devices.
Logged | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 All rights reserved.