Please login or register.

Login with username, password and session length
Advanced search  

News:

Author Topic: AHP 3.3.18 loading problems  (Read 453 times)

jayem

  • Jr. Member
  • **
  • Helpful Post Rating: 0
  • Posts: 10
AHP 3.3.18 loading problems
« on: June 25, 2021, 04:48:55 PM »

AHP version 3.3.18 will not run after initial install. .  If I delete the program and reinstall it runs fine until I power down and then with a normal boot it will not load.  I get an error message indicating: error getting X10 interface.  Detail indicates error with ntdll.dll.  I am running Windows 7  64 bit system.  AHP works well on my computers running Windows 7  32 bit and Windows 10 64 bit.  Same problem in SAFE mode.  Have run CHKDSK ,  SFC and memory diagnostics. ntdll.dll version 6.1.7601.24384  About a year and a half ago AHP ran just fine, but I stopped running AHP on the Windows 7 system and just recently returned  on this computer which is now a dual boot system..  It would seem that something in the OS has changed.  Yes I allready know that Windows 7 has been abandoned by Microsoft.  I find it hard to give up on old friends.  That is why I still run X10.  I have looked through the history but cannot find anything specific to ntdll.dll problems.  This particular dll is critical to the OS and trying to replace it generally results in the blue screen of death.
As always any help will be appreciated.

Interesting.  I can open Active Home Pro.chm and I can open AHP_smartmacros.chm and X10hardware setup help. AHP 3.3.18 will fail after install and power down and attempt to open on second try.
« Last Edit: June 26, 2021, 11:54:58 AM by jayem »
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 276
  • Posts: 10305
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: AHP 3.3.18 loading problems
« Reply #2 on: June 26, 2021, 09:22:10 AM »

Windows updates have plagued AHP since Window 98. Each update changed drivers and security settings many time stopping x10.nets from working.
 I no longer run AHP however I did have it running in Windows 10 64 bit without issues by not having AHP installed it the Program Files x86 folder ( I ran from c:/AHP) and setting windows to not auto update drivers.

 You may want to consider looking at a different software and a different OS. A Raspberry pi (which I use)makes a nice inexpensive option and there are several automation programs that run on it that support x10.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.