Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: 1 2 [3] 4

Author Topic: Net.WebService GetData() problem after Raspberry Pi update  (Read 2722 times)

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #30 on: May 31, 2020, 09:09:30 AM »

I believe I am running the latest version of HG - I updated recently when Gene had posted his last update.
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #31 on: May 31, 2020, 09:46:58 AM »

I believe I am running the latest version of HG - I updated recently when Gene had posted his last update.

Ok. You mentioned in the issue you were running 1.1 r527 https://github.com/genielabs/HomeGenie/issues/403
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #32 on: May 31, 2020, 11:34:08 AM »

While youíre waiting on a fix to your problem you might want to try change the time and date on the Pi to pre 30th May as an experiment and try making calls to the OW server via HG. It should confirm the expiry certs issue for you if you receive back valid data in HG.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 276
  • Posts: 10305
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #33 on: May 31, 2020, 11:55:23 AM »

When you post a issue HG github fills in  HG version  as 1.1-stable 527 many users over look this and don't change it.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #34 on: May 31, 2020, 03:24:30 PM »

Itís a game changer as far a security issues are concerned. There are still users on v527 particularly those who have a long time stable setup and donít want to tempt fate by upgrading it. Totally understandable.

I donít see the OW issue being resolved any time soon. I donít think itís as straightforward as Gene makes it out to be. Previous security cert issues with HG in the past related to Mono but I think issue relates to Java. I maybe wrong. I canít see a service like OW letting their certs lapse like that without having previously attended to them.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 276
  • Posts: 10305
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #35 on: May 31, 2020, 04:35:30 PM »

I donít see the OW issue being resolved any time soon. I donít think itís as straightforward as Gene makes it out to be. Previous security cert issues with HG in the past related to Mono but I think issue relates to Java. I maybe wrong. I canít see a service like OW letting their certs lapse like that without having previously attended to them.
I hope your wrong, however since the jkutils  openweathermap works( at least for me) there is an alternative to get OW data. I usually  like to have 2 weather pull options available so I may have to look into other sources. Mayby code so if one source fails HG switches to the other for data.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #36 on: May 31, 2020, 04:59:07 PM »

Can you share the JK utils weather program with me - I'd like to try that for now
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #37 on: May 31, 2020, 05:35:26 PM »

Can you share the JK utils weather program with me - I'd like to try that for now

Did you see the workaround I posted on the GitHub. Try it and let me know if it works.
Logged

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #38 on: May 31, 2020, 05:47:06 PM »

Yes, I was actually going to try it right now.
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #39 on: May 31, 2020, 05:58:36 PM »

Yes, I was actually going to try it right now.

Just make sure youíve taken an image of your SD card before you try it. The workaround should tie you over until a permanent solution is found. Itís always better to try resolve the issue than look for an alternative. Iím surprised the author Gene didnít attempt to resolve the issue instead of confirming what we already knew.
Logged

Tuicemen

  • Administrator
  • Hero Member
  • ****
  • Helpful Post Rating: 276
  • Posts: 10305
  • I don't work for X10, I use it successfuly!
    • Tuicemen Forum
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #40 on: May 31, 2020, 05:59:26 PM »

Can you share the JK utils weather program with me - I'd like to try that for now
you can get it from inside HG using the package manager.
Logged
Please Read Topic:
General Forum Etiquette
Before you post!

Find extra info @ My forum

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #41 on: May 31, 2020, 06:05:24 PM »

OK, I can confirm that the work around (which is what it is right, not a fix - that will hopefully come from OpenWeatherMap when they do something to update their certificate) posted on GitHub here will allow the weather program and widget to work again:

https://github.com/genielabs/HomeGenie/issues/403#issuecomment-636527604

Thank you :)

Tuicemen - I will take a look at the jk utils version, I'm curious why that one still worked and it may be possible to work in a backup using that into the OpenWeatherMap Program.
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #42 on: May 31, 2020, 06:09:38 PM »

OK, I can confirm that the work around (which is what it is right, not a fix - that will hopefully come from OpenWeatherMap when they do something to update their certificate) posted on GitHub here will allow the weather program and widget to work again:

https://github.com/genielabs/HomeGenie/issues/403#issuecomment-636527604

Thank you :)

Tuicemen - I will take a look at the jk utils version, I'm curious why that one still worked and it may be possible to work in a backup using that into the OpenWeatherMap Program.

Could you update your post to reflect this solution on HomeGenie.Club and GitHub. I donít use OW but thereís nothing more annoying than looking at a program that doesnít work.
Logged

soxfan1966

  • Hero Member
  • *****
  • Helpful Post Rating: 3
  • Posts: 379
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #43 on: May 31, 2020, 06:14:16 PM »

Yup, I did.  Thanks
Logged

petera

  • PI Expert
  • Hero Member
  • ******
  • Helpful Post Rating: 21
  • Posts: 1686
Re: Net.WebService GetData() problem after Raspberry Pi update
« Reply #44 on: May 31, 2020, 06:39:57 PM »

Yup, I did.  Thanks

Not a bad turnaround with a solution. I imagine youíd have been waiting a while otherwise  rofl
Logged
Pages: 1 2 [3] 4
 

X10.com | About X10 | X10 Security Systems | Cameras| Package Deals
© Copyright 2014-2016 X10.com All rights reserved.